summaryrefslogtreecommitdiff
path: root/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild')
-rw-r--r--net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild b/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild
new file mode 100644
index 000000000000..5e92f7f7e0e6
--- /dev/null
+++ b/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+DESCRIPTION="Mobile UI for kismet"
+HOMEPAGE="https://github.com/elkentaro/KismetMobileDashboard"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/elkentaro/KismetMobileDashboard.git"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+ SRC_URI="https://github.com/elkentaro/KismetMobileDashboard/archive/V1.5-beta.1.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/KismetMobileDashboard-1.5-beta.1"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-wireless/kismet"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ KIS_SRC_DIR="/usr/share/kismet" emake
+}
+
+src_install() {
+ DESTDIR="${ED}" KIS_SRC_DIR="/usr/share/kismet" emake install
+}