summaryrefslogtreecommitdiff
path: root/sci-geosciences/mc2bsbh/mc2bsbh-0.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/mc2bsbh/mc2bsbh-0.0.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/mc2bsbh/mc2bsbh-0.0.9.ebuild')
-rw-r--r--sci-geosciences/mc2bsbh/mc2bsbh-0.0.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-geosciences/mc2bsbh/mc2bsbh-0.0.9.ebuild b/sci-geosciences/mc2bsbh/mc2bsbh-0.0.9.ebuild
new file mode 100644
index 000000000000..f828f7523918
--- /dev/null
+++ b/sci-geosciences/mc2bsbh/mc2bsbh-0.0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="MapCal to BSBchart Header Utility"
+HOMEPAGE="http://www.dacust.com/inlandwaters/mapcal/"
+SRC_URI="http://www.dacust.com/inlandwaters/mapcal/${PN}/${PN}-beta09.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ $(tc-getCXX) ${LDFLAGS} ${CXXFLAGS} -o ${PN} ${PN}.cpp || die
+}
+
+src_install() {
+ dobin "${PN}"
+}