summaryrefslogtreecommitdiff
path: root/sci-geosciences/routino/routino-3.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /sci-geosciences/routino/routino-3.1.1.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'sci-geosciences/routino/routino-3.1.1.ebuild')
-rw-r--r--sci-geosciences/routino/routino-3.1.1.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/sci-geosciences/routino/routino-3.1.1.ebuild b/sci-geosciences/routino/routino-3.1.1.ebuild
index 54aadaee9dd2..724e40b20799 100644
--- a/sci-geosciences/routino/routino-3.1.1.ebuild
+++ b/sci-geosciences/routino/routino-3.1.1.ebuild
@@ -1,7 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Routing application based on openstreetmap data"
HOMEPAGE="http://www.routino.org/"
SRC_URI="http://www.routino.org/download/${P}.tgz"
@@ -10,10 +13,16 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=""
-PATCHES=( "${FILESDIR}"/${P}.patch )
-src_configure() {
- :
+src_prepare() {
+ eapply "${FILESDIR}"/${P}.patch
+
+ sed -i -e "s@libdir=\(.*\)@libdir=\$(prefix)/$(get_libdir)@" \
+ -e "s@CC=gcc@CC=$(tc-getCC)@" \
+ -e "s@LD=gcc@LD=$(tc-getCC)@" \
+ Makefile.conf || die "failed sed"
+
+ eapply_user
}
src_compile() {