summaryrefslogtreecommitdiff
path: root/sci-libs/clblas/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/clblas/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/clblas/files')
-rw-r--r--sci-libs/clblas/files/clblas-2.10-disable-multilib-cflags.patch20
-rw-r--r--sci-libs/clblas/files/clblas-2.10-fix-blas-dot-calls.patch59
-rw-r--r--sci-libs/clblas/files/clblas-2.10-fix-doxygen-output-dir.patch16
-rw-r--r--sci-libs/clblas/files/clblas-2.10-fix-pthread-linkage.patch18
-rw-r--r--sci-libs/clblas/files/clblas-2.10-use-boost-dynamic-libs.patch16
-rw-r--r--sci-libs/clblas/files/clblas-2.10-use-system-mathjax.patch18
6 files changed, 147 insertions, 0 deletions
diff --git a/sci-libs/clblas/files/clblas-2.10-disable-multilib-cflags.patch b/sci-libs/clblas/files/clblas-2.10-disable-multilib-cflags.patch
new file mode 100644
index 000000000000..a7e59d913f06
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.10-disable-multilib-cflags.patch
@@ -0,0 +1,20 @@
+Description: disable multilib flags
+Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Forwarded: not-needed
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -296,9 +296,9 @@
+ # Don't use -rpath.
+ set(CMAKE_SKIP_RPATH ON CACHE BOOL "Skip RPATH" FORCE)
+
+- set(CMAKE_C_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_C_FLAGS}")
+- set(CMAKE_CXX_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_CXX_FLAGS}")
+- set(CMAKE_Fortran_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_Fortran_FLAGS}")
++ #set(CMAKE_C_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_C_FLAGS}")
++ #set(CMAKE_CXX_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_CXX_FLAGS}")
++ #set(CMAKE_Fortran_FLAGS "-m${TARGET_PLATFORM} ${CMAKE_Fortran_FLAGS}")
+
+ if(TARGET_PLATFORM EQUAL 32)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-builtin")
diff --git a/sci-libs/clblas/files/clblas-2.10-fix-blas-dot-calls.patch b/sci-libs/clblas/files/clblas-2.10-fix-blas-dot-calls.patch
new file mode 100644
index 000000000000..cc2c6c3c1766
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.10-fix-blas-dot-calls.patch
@@ -0,0 +1,59 @@
+diff --git a/src/tests/correctness/blas-lapack.c b/src/tests/correctness/blas-lapack.c
+index 9687bdf..54666b1 100644
+--- a/src/tests/correctness/blas-lapack.c
++++ b/src/tests/correctness/blas-lapack.c
+@@ -655,7 +655,7 @@ complex cdotu( int n, complex *x, int incx, complex *y, int incy)
+ #elif defined( __APPLE__)
+ cblas_cdotu_sub(n, x, incx, y, incy, &ans);
+ #else
+- cdotusub_(&n, x, &incx, y, &incy, &ans);
++ ans = cdotu_(&n, x, &incx, y, &incy);
+ #endif
+
+ return ans;
+@@ -670,7 +670,7 @@ doublecomplex zdotu( int n, doublecomplex *x, int incx, doublecomplex *y, int i
+ #elif defined(__APPLE__)
+ cblas_zdotu_sub(n, x, incx, y, incy, &ans);
+ #else
+- zdotusub_(&n, x, &incx, y, &incy, &ans);
++ ans = zdotu_(&n, x, &incx, y, &incy);
+ #endif
+
+ return ans;
+@@ -685,7 +685,7 @@ complex cdotc( int n, complex *x, int incx, complex *y, int incy)
+ #elif defined(__APPLE__)
+ cblas_cdotc_sub(n, x, incx, y, incy, &ans);
+ #else
+- cdotcsub_(&n, x, &incx, y, &incy, &ans);
++ ans = cdotc_(&n, x, &incx, y, &incy);
+ #endif
+
+ return ans;
+@@ -700,7 +700,7 @@ doublecomplex zdotc( int n, doublecomplex *x, int incx, doublecomplex *y, int i
+ #elif defined(__APPLE__)
+ cblas_zdotc_sub(n, x, incx, y, incy, &ans);
+ #else
+- zdotcsub_(&n, x, &incx, y, &incy, &ans);
++ ans = zdotc_(&n, x, &incx, y, &incy);
+ #endif
+
+ return ans;
+diff --git a/src/tests/correctness/blas-lapack.h b/src/tests/correctness/blas-lapack.h
+index d2db1aa..8619e1e 100644
+--- a/src/tests/correctness/blas-lapack.h
++++ b/src/tests/correctness/blas-lapack.h
+@@ -1170,10 +1170,10 @@ double ddot_(int *n, double *x, int *incx, double* y, int *incy);
+ complex cdotc_(int *n, complex *x, int *incx, complex* y, int *incy);
+ doublecomplex zdotc_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy);
+ #else
+- void cdotusub_(int *n, complex *x, int *incx, complex* y, int *incy, complex *ans);
+- void zdotusub_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy, doublecomplex *ans);
+- void cdotcsub_(int *n, complex *x, int *incx, complex* y, int *incy, complex *ans);
+- void zdotcsub_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy, doublecomplex *ans);
++ complex cdotu_(int *n, complex *x, int *incx, complex* y, int *incy);
++ doublecomplex zdotu_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy);
++ complex cdotc_(int *n, complex *x, int *incx, complex* y, int *incy);
++ doublecomplex zdotc_(int *n, doublecomplex *x, int *incx, doublecomplex* y, int *incy);
+ #endif
+
+ void sswap_(int *n, float *x, int *incx, float* y, int *incy);
diff --git a/sci-libs/clblas/files/clblas-2.10-fix-doxygen-output-dir.patch b/sci-libs/clblas/files/clblas-2.10-fix-doxygen-output-dir.patch
new file mode 100644
index 000000000000..31abb89b1c3a
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.10-fix-doxygen-output-dir.patch
@@ -0,0 +1,16 @@
+Description: use system mathjax instead of remote
+Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Forwarded: not-needed
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/doc/clBLAS.doxy
++++ b/doc/clBLAS.doxy
+@@ -52,7 +52,7 @@
+ # If a relative path is entered, it will be relative to the location
+ # where doxygen was started. If left blank the current directory will be used.
+
+-OUTPUT_DIRECTORY = ..\..\bin\clBLAS.doxy
++OUTPUT_DIRECTORY =
+
+ # If the CREATE_SUBDIRS tag is set to YES, then doxygen will create
+ # 4096 sub-directories (in 2 levels) under the output directory of each output
diff --git a/sci-libs/clblas/files/clblas-2.10-fix-pthread-linkage.patch b/sci-libs/clblas/files/clblas-2.10-fix-pthread-linkage.patch
new file mode 100644
index 000000000000..aa99529df034
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.10-fix-pthread-linkage.patch
@@ -0,0 +1,18 @@
+Description: fix missing linkage with pthread
+Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Forwarded: no
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/library/CMakeLists.txt
++++ b/src/library/CMakeLists.txt
+@@ -888,6 +888,10 @@
+ set_target_properties( clBLAS PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
+ target_link_libraries(clBLAS ${OPENCL_LIBRARIES} ${MATH_LIBRARY})
+
++set(THREADS_PREFER_PTHREAD_FLAG ON)
++find_package(Threads REQUIRED)
++target_link_libraries(clBLAS ${CMAKE_THREAD_LIBS_INIT})
++
+ # CPack configuration; include the executable into the package
+ install( TARGETS clBLAS
+ EXPORT Library
diff --git a/sci-libs/clblas/files/clblas-2.10-use-boost-dynamic-libs.patch b/sci-libs/clblas/files/clblas-2.10-use-boost-dynamic-libs.patch
new file mode 100644
index 000000000000..57c585da11fc
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.10-use-boost-dynamic-libs.patch
@@ -0,0 +1,16 @@
+Description: use Boost shared libraries instead of static
+Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Forwarded: no
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -270,7 +270,7 @@
+
+ # Find Boost on the system, and configure the type of boost build we want
+ set( Boost_USE_MULTITHREADED ON )
+-set( Boost_USE_STATIC_LIBS ON )
++set( Boost_USE_STATIC_LIBS OFF )
+ set( Boost_DETAILED_FAILURE_MSG ON )
+ set( Boost_DEBUG ON )
+ set( Boost_ADDITIONAL_VERSIONS "1.44.0" "1.44" "1.47.0" "1.47" )
diff --git a/sci-libs/clblas/files/clblas-2.10-use-system-mathjax.patch b/sci-libs/clblas/files/clblas-2.10-use-system-mathjax.patch
new file mode 100644
index 000000000000..775a669e96a8
--- /dev/null
+++ b/sci-libs/clblas/files/clblas-2.10-use-system-mathjax.patch
@@ -0,0 +1,18 @@
+Description: fix output directory for documentation
+ Use default doxygen directory, i.e. under docs/html, rather than the
+ inappropriate path set by upstream.
+Author: Ghislain Antony Vaillant <ghisvail@gmail.com>
+Forwarded: no
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/doc/clBLAS.doxy
++++ b/doc/clBLAS.doxy
+@@ -1223,7 +1223,7 @@
+ # installing MathJax. However, it is strongly recommended to install a local
+ # copy of MathJax from http://www.mathjax.org before deployment.
+
+-MATHJAX_RELPATH = http://www.mathjax.org/mathjax
++MATHJAX_RELPATH = /usr/share/javascript/mathjax
+
+ # The MATHJAX_EXTENSIONS tag can be used to specify one or MathJax extension
+ # names that should be enabled during MathJax rendering.