summaryrefslogtreecommitdiff
path: root/sci-libs/qd/qd-2.3.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /sci-libs/qd/qd-2.3.23.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'sci-libs/qd/qd-2.3.23.ebuild')
-rw-r--r--sci-libs/qd/qd-2.3.23.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/qd/qd-2.3.23.ebuild b/sci-libs/qd/qd-2.3.23.ebuild
new file mode 100644
index 000000000000..d3c5bfd71d45
--- /dev/null
+++ b/sci-libs/qd/qd-2.3.23.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools fortran-2
+
+DESCRIPTION="Quad-double and double-double float arithmetics"
+HOMEPAGE="https://www.davidhbailey.com/dhbsoftware/"
+SRC_URI="https://www.davidhbailey.com/dhbsoftware/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 doc fortran"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-ieee-add \
+ --disable-sloppy-mul \
+ --disable-sloppy-div \
+ --enable-inline \
+ $(use_enable cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4) fma) \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+
+ dosym qd_real.h /usr/include/qd/qd.h
+ dosym dd_real.h /usr/include/qd/dd.h
+
+ if ! use doc; then
+ rm "${ED}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}