summaryrefslogtreecommitdiff
path: root/sci-libs/shapelib/shapelib-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /sci-libs/shapelib/shapelib-1.5.0.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'sci-libs/shapelib/shapelib-1.5.0.ebuild')
-rw-r--r--sci-libs/shapelib/shapelib-1.5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/shapelib/shapelib-1.5.0.ebuild b/sci-libs/shapelib/shapelib-1.5.0.ebuild
new file mode 100644
index 000000000000..91abc76af145
--- /dev/null
+++ b/sci-libs/shapelib/shapelib-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library for manipulating ESRI Shapefiles"
+HOMEPAGE="http://shapelib.maptools.org/"
+SRC_URI="http://download.osgeo.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+src_prepare() {
+ default
+ rm -f m4/* || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --includedir="${EPREFIX}"/usr/include/libshp \
+ --prefix="${EPREFIX}"/usr
+}
+
+src_install() {
+ use doc && HTML_DOCS=( web/. )
+ default
+
+ if ! use static-libs; then
+ find "${ED}" \( -name '*.la' -o -name '*.a' \) -delete || die
+ fi
+}