summaryrefslogtreecommitdiff
path: root/sci-mathematics/gfan/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /sci-mathematics/gfan/files
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'sci-mathematics/gfan/files')
-rw-r--r--sci-mathematics/gfan/files/gfan-0.5-double-declare-fix.patch12
-rw-r--r--sci-mathematics/gfan/files/gfan-0.5-fix-build-system.patch55
-rw-r--r--sci-mathematics/gfan/files/gfan-0.5-fix-gcc9.patch68
-rw-r--r--sci-mathematics/gfan/files/gfan-0.5-gcc6.1-compat.patch70
4 files changed, 0 insertions, 205 deletions
diff --git a/sci-mathematics/gfan/files/gfan-0.5-double-declare-fix.patch b/sci-mathematics/gfan/files/gfan-0.5-double-declare-fix.patch
deleted file mode 100644
index 239540884011..000000000000
--- a/sci-mathematics/gfan/files/gfan-0.5-double-declare-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -U 3 -dHrN gfan0.5/app_minkowski.cpp gfan0.5-new/app_minkowski.cpp
---- gfan0.5/app_minkowski.cpp 2011-01-23 12:21:47.000000000 -0500
-+++ gfan0.5-new/app_minkowski.cpp 2012-06-29 15:23:48.604280985 -0400
-@@ -160,7 +160,7 @@
- //log0 fprintf(Stderr,"4");
- f.insert(c);
- //log0 fprintf(Stderr,"5\n");
-- static int i;
-+ // static int i;
- //log0 fprintf(Stderr,"inserted:%i\n",++i);
- }
- log1 fprintf(Stderr,"Resolving symmetries.\n");
diff --git a/sci-mathematics/gfan/files/gfan-0.5-fix-build-system.patch b/sci-mathematics/gfan/files/gfan-0.5-fix-build-system.patch
deleted file mode 100644
index 3bf96ed088ce..000000000000
--- a/sci-mathematics/gfan/files/gfan-0.5-fix-build-system.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,7 +1,5 @@
- ALL: default
-
--# GPROFFLAG = -pg
-- GPROFFLAG = -g
-
- PREFIX?=/usr/local
-
-@@ -77,16 +75,13 @@
-
- SHELL = /bin/sh
- #ARCH = LINUX
--CC = gcc
- CLINKER = $(CC)
--CXX = g++
- CCLINKER = $(CXX)
--#OPTFLAGS = -O2 -DGMPRATIONAL -DNDEBUG
--OPTFLAGS = -O2 -DGMPRATIONAL -Wuninitialized
-
--CFLAGS = $(OPTFLAGS) $(GPROFFLAG) $(ADDITIONALINCLUDEOPTIONS) #-pedantic
--CCFLAGS = $(CFLAGS)
--FFLAGS = $(OPTFLAGS)
-+
-+CFLAGS += $(GPROFFLAG) $(ADDITIONALINCLUDEOPTIONS) -Wuninitialized
-+CXXFLAGS += $(GPROFFLAG) $(ADDITIONALINCLUDEOPTIONS) -Wuninitialized
-+CPPFLAGS += -DGMPRATIONAL -DNDEBUG
-
- CATSOBJECTS = $(GCATSPATH)lp_cdd.o \
- $(SOPLEX_OBJECTS) \
-@@ -317,7 +312,7 @@
- default: $(OBJECTS) $(ADDITIONALOBJECTS) $(EXECS)
-
- $(MAIN): $(OBJECTS)
-- $(CCLINKER) $(OBJECTS) $(ADDITIONALLINKOPTIONS) $(GPROFFLAG) -o $(MAIN)
-+ $(CCLINKER) $(LDFLAGS) $(OBJECTS) $(ADDITIONALLINKOPTIONS) $(GPROFFLAG) -o $(MAIN)
-
- release:
- rm -f -r $(RELEASEDIR)/*
-@@ -430,14 +425,6 @@
- cp gfanlib.h gfanlib/
- cp gfanlib_* gfanlib/
- tar zcf - gfanlib > gfanlib.tar.gz
--.c.o:
-- $(CC) $(CFLAGS) -c $<
--.cc.o:
-- $(CXX) -c $<
--.cpp.o:
-- $(CXX) $(CFLAGS) -c $<
--.C.o:
-- $(CXX) -c $<
- # wget http://ftp.sunet.se/pub/gnu/gmp/gmp-4.2.2.tar.gz
- # tar -xzvf gmp-4.2.2.tar.gz
- # cd gmp-4.2.2
diff --git a/sci-mathematics/gfan/files/gfan-0.5-fix-gcc9.patch b/sci-mathematics/gfan/files/gfan-0.5-fix-gcc9.patch
deleted file mode 100644
index 930baf9edcf2..000000000000
--- a/sci-mathematics/gfan/files/gfan-0.5-fix-gcc9.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-https://bugs.gentoo.org/686484
-
-polyhedralfan.h: At global scope:
-polyhedralfan.h:77:24: error: friend declaration of ‘PolyhedralFan refinement(const PolyhedralFan&, const PolyhedralFan&, int, bool)’ specifies default arguments and isn’t a definition [-fpermissive]
- 77 | friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
- | ^~~~~~~~~~
-
---- a/gfanlib_polyhedralfan.h
-+++ b/gfanlib_polyhedralfan.h
-@@ -24,6 +24,8 @@
- typedef std::map<int,IntVectorList> IncidenceList;
-
-
-+class PolyhedralFan;
-+PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
-
- /** A PolyhedralFan is simply a collection of canonicalized PolyhedralCones.
- * It contains no combinatorial information in the sense of a polyhedral complex.
-@@ -52,7 +54,7 @@
- int getAmbientDimension()const;
- int getMaxDimension()const;
- int getMinDimension()const;
-- friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
-+ friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension, bool allowASingleConeOfCutOffDimension);
- ZMatrix getRays(int dim=1);//This can be called for other dimensions than 1. The term "Rays" still makes sense modulo the common linearity space
- ZMatrix getRelativeInteriorPoints();
- void insert(ZCone const &c);
---- a/halfopencone.h
-+++ b/halfopencone.h
-@@ -6,6 +6,9 @@
-
- #include "polyhedralfan.h"
-
-+class HalfOpenCone;
-+HalfOpenCone intersection(const HalfOpenCone &a, const HalfOpenCone &b, bool findFacets=false);
-+
- class HalfOpenCone{
- static void appendList(IntegerVectorList &to, IntegerVectorList const &from, int appendValue);
- int liftedDimension;//ambient
-@@ -18,7 +21,7 @@
- HalfOpenCone(int dimension_, IntegerVectorList const &equations, IntegerVectorList const &nonstrict, IntegerVectorList const &strict, bool findFacets=false, bool canonicalize=false);
- HalfOpenCone(int ambientDimension);//full space
- bool isEmpty();
-- friend HalfOpenCone intersection(const HalfOpenCone &a, const HalfOpenCone &b, bool findFacets=false);
-+ friend HalfOpenCone intersection(const HalfOpenCone &a, const HalfOpenCone &b, bool findFacets);
- friend bool haveEmptyIntersection(const HalfOpenCone &a, const HalfOpenCone &b);
- PolyhedralCone closure();
- void splitIntoRelativelyOpenCones(list<HalfOpenCone> &l);
---- a/polyhedralfan.h
-+++ b/polyhedralfan.h
-@@ -30,6 +30,8 @@
- FPF_default=2+4+8
- };
-
-+class PolyhedralFan;
-+PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
-
- /** A PolyhedralFan is simply a collection of canonicalized PolyhedralCones.
- * It contains no combinatorial information in the sense of a polyhedral complex.
-@@ -74,7 +76,7 @@
- int getAmbientDimension()const;
- int getMaxDimension()const;
- int getMinDimension()const;
-- friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension=-1, bool allowASingleConeOfCutOffDimension=false);
-+ friend PolyhedralFan refinement(const PolyhedralFan &a, const PolyhedralFan &b, int cutOffDimension, bool allowASingleConeOfCutOffDimension);
- friend PolyhedralFan product(const PolyhedralFan &a, const PolyhedralFan &b);
- IntegerVectorList getRays(int dim=1);//This can be called for other dimensions than 1. The term "Rays" still makes sense modulo the common linearity space
- IntegerVectorList getRelativeInteriorPoints();
diff --git a/sci-mathematics/gfan/files/gfan-0.5-gcc6.1-compat.patch b/sci-mathematics/gfan/files/gfan-0.5-gcc6.1-compat.patch
deleted file mode 100644
index 8479557b61bb..000000000000
--- a/sci-mathematics/gfan/files/gfan-0.5-gcc6.1-compat.patch
+++ /dev/null
@@ -1,70 +0,0 @@
---- a/app_fiberpolytope.cpp
-+++ b/app_fiberpolytope.cpp
-@@ -63,7 +63,7 @@
-
- /* If the vector configuration B does not have full rank then
- change coordinates. */
-- if(rank(B)!=B.getHeight())
-+ if(rank_(B)!=B.getHeight())
- {
- FieldMatrix M=integerMatrixToFieldMatrix(B,Q);
- M.reduce(false,true);//force integer operations - preserving volume
-@@ -83,7 +83,7 @@
- log1 debug<<"Done computing restricting cone\n";
-
- debug<<B.getRows();
-- debug<<int(rank(B));
-+ debug<<int(rank_(B));
-
- Triangulation2 t(B);
- log1 debug<<"Computing initial triangulation\n";
-@@ -143,7 +143,7 @@
- */
- /* If the vector configuration A does not have full rank then
- change coordinates. */
--/* if(rank(A)!=A.getHeight())
-+/* if(rank_(A)!=A.getHeight())
- {
- FieldMatrix M=integerMatrixToFieldMatrix(A,Q);
- M.reduce(false,true);//force integer operations - preserving volume
---- a/app_secondaryfan.cpp
-+++ b/app_secondaryfan.cpp
-@@ -307,7 +307,7 @@
-
- if(scaleOption.getValue())
- {
-- if(rank(A)!=A.getHeight())
-+ if(rank_(A)!=A.getHeight())
- {
- cerr << "The vector configuration must have full rank in order to use the scale option.\n";
- assert(0);
-@@ -342,7 +342,7 @@
-
- /* If the vector configuration A does not have full rank then
- change coordinates. */
-- if(rank(A)!=A.getHeight())
-+ if(rank_(A)!=A.getHeight())
- {
- FieldMatrix M=integerMatrixToFieldMatrix(A,Q);
- M.reduce(false,true);//force integer operations - preserving volume
---- a/matrix.cpp
-+++ b/matrix.cpp
-@@ -61,7 +61,7 @@
-
- #include "linalg.h"
-
--int rank(IntegerMatrix const &m)
-+int rank_(IntegerMatrix const &m)
- {
- return integerMatrixToFieldMatrix(m,Q).rank();
- }
---- a/matrix.h
-+++ b/matrix.h
-@@ -147,6 +147,6 @@
-
- FloatMatrix integerToFloatMatrix(IntegerMatrix const &m);
- IntegerVector flattenMatrix(IntegerMatrix const &m);
--int rank(IntegerMatrix const &m);
-+int rank_(IntegerMatrix const &m);
-
- #endif