summaryrefslogtreecommitdiff
path: root/sci-mathematics/spass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-15 09:01:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-15 09:01:56 +0100
commite8f81810baa21f490d6910e8e2d424546b72a333 (patch)
treedb79151c528a566490ffcac0d7b64484e12b4762 /sci-mathematics/spass
parentd00821e77f72d4af4ea30158c1c6e18ffff0875b (diff)
gentoo resync : 15.09.2019
Diffstat (limited to 'sci-mathematics/spass')
-rw-r--r--sci-mathematics/spass/Manifest3
-rw-r--r--sci-mathematics/spass/metadata.xml17
-rw-r--r--sci-mathematics/spass/spass-3.9.ebuild145
3 files changed, 0 insertions, 165 deletions
diff --git a/sci-mathematics/spass/Manifest b/sci-mathematics/spass/Manifest
deleted file mode 100644
index 3f6eac8e73fd..000000000000
--- a/sci-mathematics/spass/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST spass39.tgz 554633 BLAKE2B ca2215f205215805eace6abae82ad281bdadd75f2a52cfe3fed43cb15a4955a4e4d2375fc73a546592315540a7596494bc0df4c53996fd9299e901f68a81ddc8 SHA512 d7ea0697426c476f2e03b2f9078b7e060671067a67fad7144bb5887a2dd3f39e19e1888f121fce546b5d6ea9a4dc458d1cbec56b59c93507e7dc2d0afa25a89b
-EBUILD spass-3.9.ebuild 4528 BLAKE2B cde0847e8e2779971f33c1901f4601083c7490082d987a3286c89b1b7c72b8f5c5824aa3762f3eab99b4748c17f0cc6e38bd6f5ced7cf66ff87e4a013b6349a0 SHA512 e00e0c0a2fe8ffc3b5e5ff193a90ed002ffb0a7173cd31837351d32e86201b4bb0296ee49e203ebba9b67f948448f93e3f8acd317f1f800691d6b8a9ed3b0a2f
-MISC metadata.xml 577 BLAKE2B 7d0a60f31459c0a514ae829d1a56efdb55ac0abb5c5202e1e8400755ae4593ef183e9770e2308545af2b17ad7e385d15c48a9ee630a3cd20d1feb5f0edc189d1 SHA512 7cd50f06b202828fd682e2f44d361b393cc89f0468001970c2ad807e26d7fa5399cba09e6805a937cfba9c56019b67ab3dec422a989e16cbb5216fa76c253285
diff --git a/sci-mathematics/spass/metadata.xml b/sci-mathematics/spass/metadata.xml
deleted file mode 100644
index 93ca493501bd..000000000000
--- a/sci-mathematics/spass/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>gienah@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription lang="en">
- SPASS: An Automated Theorem Prover for First-Order Logic with Equality.
- </longdescription>
- <use>
- <flag name="isabelle">Add integration support for the Isabelle/HOL theorem prover.</flag>
- </use>
-</pkgmetadata>
diff --git a/sci-mathematics/spass/spass-3.9.ebuild b/sci-mathematics/spass/spass-3.9.ebuild
deleted file mode 100644
index c702deaec240..000000000000
--- a/sci-mathematics/spass/spass-3.9.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-MY_PV=$(ver_rs 1- '' "${PV}")
-MY_P="${PN}${MY_PV}"
-
-DESCRIPTION="An Automated Theorem Prover for First-Order Logic with Equality"
-HOMEPAGE="http://www.spass-prover.org/"
-SRC_URI="http://www.spass-prover.org/download/sources/${MY_P}.tgz"
-
-LICENSE="BSD-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="isabelle"
-
-RDEPEND="isabelle? (
- sci-mathematics/isabelle:=
- )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- mkdir -p "${P}" || die
- cd "${S}" || die
- unpack "${MY_P}.tgz"
-}
-
-src_compile() {
- einfo "generating parsers"
- bison -d -p pro_ -o proparser.c proparser.y || die
- bison -d -p tptp_ -o tptpparser.c tptpparser.y || die
- bison -d -p ia_ -o iaparser.c iaparser.y || die
-
- einfo "generating lexers"
- flex -Ppro_ -o proscanner.c proscanner.l || die
- flex -Ptptp_ -o tptpscanner.c tptpscanner.l || die
- flex -Pia_ -o iascanner.c iascanner.l || die
-
- einfo "compiling sources"
- local x
- for x in *.c
- do
- $(tc-getCC) \
- ${CPPFLAGS} ${CFLAGS} \
- -c -o ${x/.c/.o} ${x} || die "compile ${x} failed"
- done
-
- einfo "linking tptp2dfg"
- $(tc-getCC) \
- ${LDFLAGS} -o tptp2dfg \
- array.o clause.o cmdline.o context.o description.o dfg_diagnostic.o \
- dfg_string_table.o dfg_token.o dfgparser.o dfglexer.o \
- tptpparser.o tptpscanner.o eml.o flags.o foldfg.o hashmap.o kbo.o \
- list.o memory.o misc.o order.o rpos.o sharing.o st.o stack.o \
- strings.o subst.o symbol.o term.o unify.o tptp2dfg.o -lm \
- || die "link tptp2dfg failed"
-
- einfo "linking dfg2ascii"
- $(tc-getCC) \
- ${LDFLAGS} -o dfg2ascii \
- array.o clause.o cmdline.o context.o description.o dfg_diagnostic.o \
- dfg_string_table.o dfg_token.o dfgparser.o dfglexer.o \
- tptpparser.o tptpscanner.o eml.o flags.o foldfg.o hashmap.o kbo.o \
- list.o memory.o misc.o order.o rpos.o sharing.o st.o stack.o \
- strings.o subst.o symbol.o term.o unify.o dfg2ascii.o -lm \
- || die "link dfg2ascii failed"
-
- einfo "linking dfg2dfg"
- $(tc-getCC) \
- ${LDFLAGS} -o dfg2dfg \
- array.o clause.o cmdline.o context.o description.o dfg_diagnostic.o \
- dfg_string_table.o dfg_token.o dfgparser.o dfglexer.o \
- tptpparser.o tptpscanner.o eml.o flags.o foldfg.o hashmap.o kbo.o \
- list.o memory.o misc.o order.o rpos.o sharing.o st.o stack.o \
- strings.o subst.o symbol.o term.o unify.o approx.o dfg2dfg.o -lm \
- || die "link dfg2dfg failed"
-
- einfo "linking SPASS"
- $(tc-getCC) \
- ${LDFLAGS} -o SPASS \
- array.o clause.o cmdline.o context.o description.o dfg_diagnostic.o \
- dfg_string_table.o dfg_token.o dfgparser.o dfglexer.o \
- tptpparser.o tptpscanner.o eml.o flags.o foldfg.o hashmap.o kbo.o \
- list.o memory.o misc.o order.o rpos.o sharing.o st.o stack.o \
- strings.o subst.o symbol.o term.o unify.o analyze.o clock.o \
- closure.o cnf.o component.o condensing.o defs.o doc-proof.o graph.o \
- hash.o hasharray.o iaparser.o iascanner.o partition.o proofcheck.o \
- ras.o renaming.o resolution.o rules-inf.o rules-red.o rules-sort.o \
- rules-split.o rules-ur.o search.o sort.o subsumption.o table.o \
- tableau.o terminator.o top.o vector.o -lm \
- || die "link SPASS failed"
-}
-
-src_install() {
- exeinto /usr/bin
- local x
- for x in tptp2dfg dfg2ascii dfg2dfg SPASS
- do
- doexe ${x}
- done
-
- if use isabelle; then
- ewarn "All open source versions of spass are broken with Isabelle 2016.1"
- ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)"
- [[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
- dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
- cat <<- EOF >> "${S}/settings"
- SPASS_HOME="${EROOT}/usr/bin"
- SPASS_VERSION="${PV}"
- EOF
- insinto "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
- doins "${S}/settings"
- fi
-}
-
-pkg_postinst() {
- if use isabelle; then
- if [ -f "${EROOT}/etc/isabelle/components" ]; then
- if egrep "contrib/${PN}-[0-9.]*" "${EROOT}/etc/isabelle/components"; then
- sed -e "/contrib\/${PN}-[0-9.]*/d" \
- -i "${EROOT}/etc/isabelle/components"
- fi
- cat <<- EOF >> "${EROOT}/etc/isabelle/components"
- contrib/${PN}-${PV}
- EOF
- fi
- fi
-}
-
-pkg_postrm() {
- if use isabelle; then
- if [ ! -f "${EROOT}/usr/bin/SPASS" ]; then
- if [ -f "${EROOT}/etc/isabelle/components" ]; then
- # Note: this sed should only match the version of this ebuild
- # Which is what we want as we do not want to remove the line
- # of a new spass being installed during an upgrade.
- sed -e "/contrib\/${PN}-${PV}/d" \
- -i "${EROOT}/etc/isabelle/components"
- fi
- fi
- fi
-}