summaryrefslogtreecommitdiff
path: root/sys-block/nbd/nbd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-block/nbd/nbd-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-block/nbd/nbd-9999.ebuild')
-rw-r--r--sys-block/nbd/nbd-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/sys-block/nbd/nbd-9999.ebuild b/sys-block/nbd/nbd-9999.ebuild
index 732367ad8970..04319fda899d 100644
--- a/sys-block/nbd/nbd-9999.ebuild
+++ b/sys-block/nbd/nbd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,14 +6,16 @@ EAPI=7
inherit systemd
DESCRIPTION="Userland client/server for kernel network block device"
-HOMEPAGE="http://nbd.sourceforge.net/"
-if [[ "${PV}" = 9999 ]] ; then
+HOMEPAGE="https://nbd.sourceforge.net/"
+if [[ ${PV} = 9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/NetworkBlockDevice/nbd.git"
else
- SRC_URI="mirror://sourceforge/nbd/${P}.tar.xz"
+ SRC_URI="https://github.com/NetworkBlockDevice/nbd/releases/download/${P}/${P}.tar.xz
+ mirror://sourceforge/nbd/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
+
LICENSE="GPL-2"
SLOT="0"
IUSE="debug gnutls netlink zlib"
@@ -27,24 +29,29 @@ RDEPEND="
zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/bison"
-if [[ "${PV}" = 9999 ]] ; then
- DEPEND+="
+if [[ ${PV} = 9999 ]] ; then
+ BDEPEND+="
app-text/docbook-sgml-dtd:4.5
app-text/docbook-sgml-utils
+ sys-devel/autoconf-archive
"
fi
src_prepare() {
default
- if [[ "${PV}" = 9999 ]] ; then
+
+ if [[ ${PV} = 9999 ]] ; then
emake -C man -f Makefile.am \
nbd-server.1.sh.in \
nbd-server.5.sh.in \
nbd-client.8.sh.in \
nbd-trdump.1.sh.in \
nbdtab.5.sh.in
+
emake -C systemd -f Makefile.am nbd@.service.sh.in
+
eautoreconf
fi
}
@@ -58,6 +65,7 @@ src_configure() {
$(use_with gnutls)
$(use_with netlink libnl)
)
+
econf "${myeconfargs[@]}"
}