summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-15.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
commitb46782805d0eed36ce9685f7e9abf25671f24d7d (patch)
tree4b7992f7355b710c35a7c4bfff9b57eb64e4c8b5 /sys-devel/clang-common/clang-common-15.0.5.ebuild
parentd4d7098dcb2f9dd257109bbcb55fd40beda1b78d (diff)
gentoo auto-resync : 21:12:2022 - 01:52:55
Diffstat (limited to 'sys-devel/clang-common/clang-common-15.0.5.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.5.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.5.ebuild b/sys-devel/clang-common/clang-common-15.0.5.ebuild
index 2fdf615be818..ee4c708e9f3c 100644
--- a/sys-devel/clang-common/clang-common-15.0.5.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.5.ebuild
@@ -12,7 +12,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="
- default-compiler-rt default-libcxx default-lld llvm-libunwind
+ default-compiler-rt default-libcxx default-lld ieee-long-double llvm-libunwind
stricter
"
@@ -88,6 +88,19 @@ src_install() {
@gentoo-gcc-install.cfg
EOF
+ # needed until https://reviews.llvm.org/D117181#3266224 is done.
+ # silently drop support on musl even if enabled, it does not support it.
+ if use ppc64 && use ieee-long-double && ! use elibc_musl; then
+ newins - gentoo-ppc64le-ieeelongdouble.cfg <<-EOF
+ # This file forces 128bit long double on ppc64le systems.
+ -mabi=ieeelongdouble
+ EOF
+
+ cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
+ @gentoo-ppc64le-ieeelongdouble.cfg
+ EOF
+ fi
+
if use stricter; then
newins - gentoo-stricter.cfg <<-EOF
# This file increases the strictness of older clang versions