summaryrefslogtreecommitdiff
path: root/sys-devel/clang-runtime/clang-runtime-15.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-18 19:56:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-18 19:56:57 +0100
commitd1262423b614597cd55d30370eb8de6bfa8f0899 (patch)
tree1a5f46b31c19b0bfcc840ab7a6ee06d7aa161c87 /sys-devel/clang-runtime/clang-runtime-15.0.3.ebuild
parentcb9a501c2ed1312c376917c1cbfc79542d799806 (diff)
gentoo auto-resync : 18:10:2022 - 19:56:57
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-15.0.3.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.3.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.3.ebuild
new file mode 100644
index 000000000000..f0ec98510540
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"