summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-15.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-18 19:56:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-18 19:56:57 +0100
commitd1262423b614597cd55d30370eb8de6bfa8f0899 (patch)
tree1a5f46b31c19b0bfcc840ab7a6ee06d7aa161c87 /sys-devel/llvm-common/llvm-common-15.0.3.ebuild
parentcb9a501c2ed1312c376917c1cbfc79542d799806 (diff)
gentoo auto-resync : 18:10:2022 - 19:56:57
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-15.0.3.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-15.0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-15.0.3.ebuild b/sys-devel/llvm-common/llvm-common-15.0.3.ebuild
new file mode 100644
index 000000000000..104c8747bbee
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-15.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}