summaryrefslogtreecommitdiff
path: root/sys-libs/freeipmi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/freeipmi/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/freeipmi/files')
-rw-r--r--sys-libs/freeipmi/files/bmc-watchdog.confd44
-rw-r--r--sys-libs/freeipmi/files/bmc-watchdog.initd.419
-rw-r--r--sys-libs/freeipmi/files/freeipmi-1.1.1-strictaliasing.patch13
-rw-r--r--sys-libs/freeipmi/files/freeipmi.icinga4
-rw-r--r--sys-libs/freeipmi/files/ipmidetectd.confd5
-rw-r--r--sys-libs/freeipmi/files/ipmiseld.confd5
6 files changed, 90 insertions, 0 deletions
diff --git a/sys-libs/freeipmi/files/bmc-watchdog.confd b/sys-libs/freeipmi/files/bmc-watchdog.confd
new file mode 100644
index 000000000000..4d39cf4d8b7d
--- /dev/null
+++ b/sys-libs/freeipmi/files/bmc-watchdog.confd
@@ -0,0 +1,44 @@
+#
+# This configuration file controls the behaviour of the bmc-watchdog daemon
+# from FreeIPMI.
+#
+# -u INT, --timer-use=INT
+# Set timer use. The timer use value can be set to one of the
+# following: 1 = BIOS FRB2, 2 = BIOS POST, 3 = OS_LOAD, 4 = SMS
+# OS, 5 = OEM.
+#
+# -p INT, --pre-timeout-interrupt=INT
+# Set pre-timeout interrupt. The pre timeout interrupt can be set
+# to one of the following: 0 = None, 1 = SMI, 2 = NMI, 3 = Messag-
+# ing Interrupt.
+#
+# -a INT, --timeout-action=INT
+# Set timeout action. The timeout action can be set to one of the
+# following: 0 = No action, 1 = Hard Reset, 2 = Power Down, 3 =
+# Power Cycle.
+#
+# -F, --clear-bios-frb2
+# Clear BIOS FRB2 Timer Use Flag.
+#
+# -P, --clear-bios-post
+# Clear BIOS POST Timer Use Flag.
+#
+# -L, --clear-os-load
+# Clear OS Load Timer Use Flag.
+#
+# -S, --clear-sms-os
+# Clear SMS/OS Timer Use Flag.
+#
+# -O, --clear-oem
+# Clear OEM Timer Use Flag.
+#
+# -i SECS, --initial-countdown=SECS
+# Set initial countdown in seconds.
+#
+# -e, --reset-period
+# Time interval to wait before resetting timer. The default is 60
+# seconds.
+#
+# For the remaining options, consult man bmc-watchdog
+#
+OPTIONS="-d -u 4 -p 0 -a 1 -F -P -L -S -O -i 900 -e 60"
diff --git a/sys-libs/freeipmi/files/bmc-watchdog.initd.4 b/sys-libs/freeipmi/files/bmc-watchdog.initd.4
new file mode 100644
index 000000000000..e0f8bf02c045
--- /dev/null
+++ b/sys-libs/freeipmi/files/bmc-watchdog.initd.4
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+extra_commands="condrestart"
+description_condrestart="Restart the service only if started already"
+
+command="/usr/sbin/${SVCNAME}"
+command_args="${OPTIONS}"
+pidfile=/var/run/$SVCNAME.pid
+
+depend() {
+ need localmount
+ use logger
+}
+
+condrestart() {
+ service_started && restart
+}
diff --git a/sys-libs/freeipmi/files/freeipmi-1.1.1-strictaliasing.patch b/sys-libs/freeipmi/files/freeipmi-1.1.1-strictaliasing.patch
new file mode 100644
index 000000000000..ecbb77f216fb
--- /dev/null
+++ b/sys-libs/freeipmi/files/freeipmi-1.1.1-strictaliasing.patch
@@ -0,0 +1,13 @@
+diff -Nuar freeipmi-1.1.1.orig/libfreeipmi/Makefile.am freeipmi-1.1.1/libfreeipmi/Makefile.am
+--- freeipmi-1.1.1.orig/libfreeipmi/Makefile.am 2012-01-02 19:26:00.000000000 +0000
++++ freeipmi-1.1.1/libfreeipmi/Makefile.am 2012-01-21 20:26:26.957801741 +0000
+@@ -25,7 +25,8 @@
+ -DIPMI_IPCKEY=\"$(localstatedir)/lib/$(PACKAGE_NAME)/ipckey\" \
+ -DIPMI_DEBUG_IPCKEY=\"$(top_builddir)/libfreeipmi/driver/ipmi-semaphores.h\" \
+ -D_GNU_SOURCE \
+- -D_REENTRANT
++ -D_REENTRANT \
++ -fno-strict-aliasing
+
+ libfreeipmi_la_LDFLAGS = \
+ -version-info @LIBFREEIPMI_VERSION_INFO@ $(VERSION_FLAGS) \
diff --git a/sys-libs/freeipmi/files/freeipmi.icinga b/sys-libs/freeipmi/files/freeipmi.icinga
new file mode 100644
index 000000000000..4c4026c72b87
--- /dev/null
+++ b/sys-libs/freeipmi/files/freeipmi.icinga
@@ -0,0 +1,4 @@
+define command {
+ command_name nagios_ipmi_sensors
+ command_line $USER1$/nagios_ipmi_sensors.pl -h $HOSTADDRESS$
+}
diff --git a/sys-libs/freeipmi/files/ipmidetectd.confd b/sys-libs/freeipmi/files/ipmidetectd.confd
new file mode 100644
index 000000000000..74245f14c0c5
--- /dev/null
+++ b/sys-libs/freeipmi/files/ipmidetectd.confd
@@ -0,0 +1,5 @@
+# This configuration file controls the behaviour of the ipmid daemon
+# from FreeIPMI.
+# See `man 8 ipmitdetectd` for further information.
+
+# OPTIONS="-c /etc/freeipmi/ipmidetectd.conf"
diff --git a/sys-libs/freeipmi/files/ipmiseld.confd b/sys-libs/freeipmi/files/ipmiseld.confd
new file mode 100644
index 000000000000..8e40a5c0c8dc
--- /dev/null
+++ b/sys-libs/freeipmi/files/ipmiseld.confd
@@ -0,0 +1,5 @@
+# This configuration file controls the behaviour of the ipmiseld daemon
+# from FreeIPMI.
+# See `man 8 ipmiseld` for further information.
+
+# OPTIONS="--config-file /etc/freeipmi/ipmiseld.conf"