summaryrefslogtreecommitdiff
path: root/sys-libs/libcap/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-libs/libcap/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-libs/libcap/files')
-rw-r--r--sys-libs/libcap/files/libcap-2.38-no_perl.patch (renamed from sys-libs/libcap/files/libcap-2.28-no_perl.patch)31
-rw-r--r--sys-libs/libcap/files/libcap-2.39-build-system-fixes.patch (renamed from sys-libs/libcap/files/libcap-2.34-build-system-fixes.patch)46
-rw-r--r--sys-libs/libcap/files/libcap-2.42-build-system-fixes.patch200
3 files changed, 241 insertions, 36 deletions
diff --git a/sys-libs/libcap/files/libcap-2.28-no_perl.patch b/sys-libs/libcap/files/libcap-2.38-no_perl.patch
index d8a20c2e1310..f3e0c468c869 100644
--- a/sys-libs/libcap/files/libcap-2.28-no_perl.patch
+++ b/sys-libs/libcap/files/libcap-2.38-no_perl.patch
@@ -1,4 +1,4 @@
-From 71ed151782c55b69ad4ce87658c0ce2ccc9c4a86 Mon Sep 17 00:00:00 2001
+From 3f76418eaf73896489129c529fac021e4f3a03c0 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Wed, 21 Nov 2018 11:00:54 +0100
Subject: [PATCH] use awk/sed instead of perl for creating header files
@@ -11,14 +11,15 @@ Forward ported from libcap-2.22 to libcap-2.26
and incorporated the gperf-3.1 fix provided by Mike Gilbert
<floppym@gentoo.org>
Forward ported from libcap-2.26 to libcap-2.28
+Forward ported from libcap-2.28 to libcap-2.38
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
---
- libcap/Makefile | 24 ++++++++++++++++++------
- 1 file changed, 18 insertions(+), 6 deletions(-)
+ libcap/Makefile | 26 +++++++++++++++++++-------
+ 1 file changed, 19 insertions(+), 7 deletions(-)
diff --git a/libcap/Makefile b/libcap/Makefile
-index 93f43bf..e2e371d 100644
+index 3d6463d..df2526c 100644
--- a/libcap/Makefile
+++ b/libcap/Makefile
@@ -22,6 +22,8 @@ MAJLIBNAME=$(LIBNAME).$(VERSION)
@@ -28,18 +29,14 @@ index 93f43bf..e2e371d 100644
+AWK = awk
+SED = sed
- all: $(MINLIBNAME) $(STALIBNAME) libcap.pc $(STAPSXLIBNAME)
+ all: $(MINLIBNAME) $(STACAPLIBNAME) libcap.pc libpsx.pc $(STAPSXLIBNAME)
-@@ -46,12 +48,22 @@ cap_names.h: _makenames
+@@ -55,17 +57,27 @@ cap_names.h: _makenames
./_makenames > cap_names.h
$(GPERF_OUTPUT): cap_names.list.h
- perl -e 'print "struct __cap_token_s { const char *name; int index; };\n%{\nconst struct __cap_token_s *__cap_lookup_name(const char *, size_t);\n%}\n%%\n"; while ($$l = <>) { $$l =~ s/[\{\"]//g; $$l =~ s/\}.*// ; print $$l; }' < $< | gperf --ignore-case --language=ANSI-C --readonly --null-strings --global-table --hash-function-name=__cap_hash_name --lookup-function-name="__cap_lookup_name" -c -t -m20 $(INDENT) > $@
- sed -e 's/unsigned int len/size_t len/' -i $@
--
--cap_names.list.h: Makefile $(KERNEL_HEADERS)/linux/capability.h
-- @echo "=> making $@ from $(KERNEL_HEADERS)/linux/capability.h"
-- perl -e 'while ($$l=<>) { if ($$l =~ /^\#define[ \t](CAP[_A-Z]+)[ \t]+([0-9]+)\s+$$/) { $$tok=$$1; $$val=$$2; $$tok =~ tr/A-Z/a-z/; print "{\"$$tok\",$$val},\n"; } }' $(KERNEL_HEADERS)/linux/capability.h | fgrep -v 0x > $@
+ (printf "%b" "struct __cap_token_s { const char *name; int index; };\n%%\n"; \
+ $(SED) -e 's:["{}]::g' -e 's:,$$::' $<) | \
+ gperf \
@@ -52,13 +49,23 @@ index 93f43bf..e2e371d 100644
+ --hash-function-name=__cap_hash_name \
+ --lookup-function-name="__cap_lookup_name" \
+ -c -t -m20 $(INDENT) > $@
+
+-# Intention is that libcap keeps up with torvalds' tree, as reflected
+-# by this maintained version of the kernel header. libcap dynamically
+-# trims the meaning of "all" capabilities down to that of the running
+-# kernel as of 2.30.
+ UAPI_HEADER := $(topdir)/libcap/include/uapi/linux/capability.h
+ cap_names.list.h: Makefile $(UAPI_HEADER)
+ @echo "=> making $@ from $(UAPI_HEADER)"
+- perl -e 'while ($$l=<>) { if ($$l =~ /^\#define[ \t](CAP[_A-Z]+)[ \t]+([0-9]+)\s+$$/) { $$tok=$$1; $$val=$$2; $$tok =~ tr/A-Z/a-z/; print "{\"$$tok\",$$val},\n"; } }' $(UAPI_HEADER) | fgrep -v 0x > $@
++ $(AWK) '($$0 ~ /^#define[[:space:]]+CAP[_A-Z]+[[:space:]]+[0-9]+[[:space:]]*$$/) { printf "{\"%s\",%s},\n", tolower($$2), $$3 }' $(UAPI_HEADER) > $@
+
+cap_names.list.h: $(KERNEL_HEADERS)/linux/capability.h Makefile
+ @echo "=> making $@ from $<"
+ $(AWK) '($$0 ~ /^#define[[:space:]]+CAP[_A-Z]+[[:space:]]+[0-9]+[[:space:]]*$$/) { printf "{\"%s\",%s},\n", tolower($$2), $$3 }' $< > $@
- $(STALIBNAME): $(CAPOBJS)
+ $(STACAPLIBNAME): $(CAPOBJS)
$(AR) rcs $@ $^
--
-2.24.0
+2.27.0
diff --git a/sys-libs/libcap/files/libcap-2.34-build-system-fixes.patch b/sys-libs/libcap/files/libcap-2.39-build-system-fixes.patch
index 126e538633b5..7ae18107f9a5 100644
--- a/sys-libs/libcap/files/libcap-2.34-build-system-fixes.patch
+++ b/sys-libs/libcap/files/libcap-2.39-build-system-fixes.patch
@@ -1,4 +1,4 @@
-From ac790bb368d309d1d2add15bbb59559d53cb05bb Mon Sep 17 00:00:00 2001
+From cc1012914a4041eb2b5fb30057f28f62c1788662 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Tue, 5 May 2020 09:52:40 +0200
Subject: [PATCH] build system fixes
@@ -19,6 +19,8 @@ Forward ported from libcap-2.25 to libcap-2.28
Forward ported from libcap-2.28 to libcap-2.29
Forward ported from libcap-2.29 to libcap-2.33
Forward ported from libcap-2.33 to libcap-2.34
+Forward ported from libcap-2.34 to libcap-2.37
+Forward ported from libcap-2.37 to libcap-2.39
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
---
@@ -27,14 +29,14 @@ Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
libcap/Makefile | 7 ++++---
pam_cap/Makefile | 8 +++++---
progs/Makefile | 2 +-
- tests/Makefile | 8 +++++---
- 6 files changed, 28 insertions(+), 22 deletions(-)
+ tests/Makefile | 6 ++++--
+ 6 files changed, 27 insertions(+), 21 deletions(-)
diff --git a/Make.Rules b/Make.Rules
-index 0fbfba0..755581d 100644
+index 98fb9db..889798e 100644
--- a/Make.Rules
+++ b/Make.Rules
-@@ -47,36 +47,38 @@ MINOR=34
+@@ -52,37 +52,39 @@ GOMAJOR=0
# Compilation specifics
KERNEL_HEADERS := $(topdir)/libcap/include/uapi
@@ -79,25 +81,26 @@ index 0fbfba0..755581d 100644
INDENT := $(shell if [ -n "$$(which indent 2>/dev/null)" ]; then echo "| indent -kr" ; fi)
DYNAMIC := $(shell if [ ! -d "$(topdir)/.git" ]; then echo yes; fi)
--GOLANG := $(shell if [ -n "$(shell go version 2>/dev/null)" ]; then echo yes ; else echo no ; fi)
-+GOLANG ?= $(shell if [ -n "$(shell go version 2>/dev/null)" ]; then echo yes ; else echo no ; fi)
+ GO := go
+-GOLANG := $(shell if [ -n "$(shell $(GO) version 2>/dev/null)" ]; then echo yes ; else echo no ; fi)
++GOLANG ?= $(shell if [ -n "$(shell $(GO) version 2>/dev/null)" ]; then echo yes ; else echo no ; fi)
ifeq ($(GOLANG),yes)
- GOROOT := $(shell go env GOROOT)
- GOCGO := $(shell if [ "$(shell go env CGO_ENABLED)" = 1 ]; then echo yes ; else echo no ; fi)
+ GOROOT := $(shell $(GO) env GOROOT)
+ GOCGO := $(shell if [ "$(shell $(GO) env CGO_ENABLED)" = 1 ]; then echo yes ; else echo no ; fi)
diff --git a/Makefile b/Makefile
-index d8cf49c..c0b10a0 100644
+index e148633..b29f5f1 100644
--- a/Makefile
+++ b/Makefile
-@@ -16,7 +16,6 @@ endif
- ifeq ($(GOLANG),yes)
+@@ -17,7 +17,6 @@ ifeq ($(GOLANG),yes)
$(MAKE) -C go $@
+ rm -f cap/go.sum
endif
- $(MAKE) -C tests $@
$(MAKE) -C progs $@
$(MAKE) -C doc $@
$(MAKE) -C kdebug $@
diff --git a/libcap/Makefile b/libcap/Makefile
-index c2cb0d1..406dfe5 100644
+index 4321c2f..3d6463d 100644
--- a/libcap/Makefile
+++ b/libcap/Makefile
@@ -21,6 +21,7 @@ PSXOBJS=$(addsuffix .o, $(PSXFILES))
@@ -117,7 +120,7 @@ index c2cb0d1..406dfe5 100644
cap_names.h: _makenames
./_makenames > cap_names.h
-@@ -75,10 +76,10 @@ $(MINLIBNAME): $(CAPOBJS)
+@@ -80,10 +81,10 @@ $(MINLIBNAME): $(CAPOBJS)
ln -sf $(MAJLIBNAME) $(LIBNAME)
%.o: %.c $(INCLS)
@@ -177,10 +180,10 @@ index 076e44f..fd13351 100644
install: all
mkdir -p -m 0755 $(FAKEROOT)$(SBINDIR)
diff --git a/tests/Makefile b/tests/Makefile
-index 3fedeca..3645ddd 100644
+index bfedbc2..2b9a801 100644
--- a/tests/Makefile
+++ b/tests/Makefile
-@@ -16,6 +16,8 @@ test: run_psx_test run_libcap_psx_test
+@@ -16,19 +16,21 @@ test: run_psx_test run_libcap_psx_test
sudotest: test run_libcap_launch_test run_libcap_launch_test
@@ -188,15 +191,10 @@ index 3fedeca..3645ddd 100644
+
install: all
- run_psx_test: psx_test psx_test_wrap
-@@ -23,16 +25,16 @@ run_psx_test: psx_test psx_test_wrap
- ./psx_test_wrap
+ run_psx_test: psx_test
+ ./psx_test
psx_test: psx_test.c $(DEPS)
-- $(CC) $(CFLAGS) $(IPATH) -DNOWRAP $< -o $@ $(LIBPSXLIB)
-+ $(CC) $(CFLAGS) $(CPPFLAGS) -DNOWRAP $< -o $@ $(LIBPSXLIB)
-
- psx_test_wrap: psx_test.c $(DEPS)
- $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBPSXLIB) -Wl,-wrap,pthread_create
+ $(CC) $(CFLAGS) $(CPPFLAGS) $< -o $@ $(LIBPSXLIB) -Wl,-wrap,pthread_create
@@ -210,5 +208,5 @@ index 3fedeca..3645ddd 100644
run_libcap_launch_test: libcap_launch_test libcap_psx_launch_test noop
sudo ./libcap_launch_test
--
-2.26.2
+2.27.0
diff --git a/sys-libs/libcap/files/libcap-2.42-build-system-fixes.patch b/sys-libs/libcap/files/libcap-2.42-build-system-fixes.patch
new file mode 100644
index 000000000000..10959cf93395
--- /dev/null
+++ b/sys-libs/libcap/files/libcap-2.42-build-system-fixes.patch
@@ -0,0 +1,200 @@
+From 8599fc87e91b7903cfb1877983615dadcbcc1b29 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 5 May 2020 09:52:40 +0200
+Subject: [PATCH] build system fixes
+
+This touches up the homebrewed build system to work much better "out of the
+box" for people. Specifically:
+ - allow toolchain vars to be set via environment
+ - CC / BUILD_CC / AR / RANLIB
+ - CFLAGS / CPPFLAGS / LDFLAGS
+ - split CPPFLAGS out of CFLAGS
+ - break -fPIC out of global CFLAGS and only use where needed
+ - use LDLIBS for libraries, not LDFLAGS
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+
+Forward ported from libcap-2.24 to libcap-2.25
+Forward ported from libcap-2.25 to libcap-2.28
+Forward ported from libcap-2.28 to libcap-2.29
+Forward ported from libcap-2.29 to libcap-2.33
+Forward ported from libcap-2.33 to libcap-2.34
+Forward ported from libcap-2.34 to libcap-2.37
+Forward ported from libcap-2.37 to libcap-2.39
+Forward ported from libcap-2.39 to libcap-2.42
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ Make.Rules | 12 +++++++-----
+ Makefile | 1 -
+ libcap/Makefile | 7 ++++---
+ pam_cap/Makefile | 8 +++++---
+ progs/Makefile | 2 +-
+ tests/Makefile | 6 ++++--
+ 6 files changed, 21 insertions(+), 15 deletions(-)
+
+diff --git a/Make.Rules b/Make.Rules
+index 8440e18..67fd4a6 100644
+--- a/Make.Rules
++++ b/Make.Rules
+@@ -52,13 +52,12 @@ GOMAJOR=0
+ # Compilation specifics
+
+ KERNEL_HEADERS := $(topdir)/libcap/include/uapi
+-IPATH += -fPIC -I$(KERNEL_HEADERS) -I$(topdir)/libcap/include
+
+ CC ?= $(CROSS_COMPILE)gcc
+ DEFINES := -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ CFLAGS ?= -O2 $(DEFINES)
+ BUILD_CC ?= $(CC)
+-BUILD_CFLAGS ?= -O2 $(DEFINES) $(IPATH)
++BUILD_CFLAGS ?= $(CFLAGS)
+ AR ?= $(CROSS_COMPILE)ar
+ RANLIB ?= $(CROSS_COMPILE)ranlib
+ DEBUG = -g #-DDEBUG
+@@ -73,16 +72,19 @@ LIBPSXLIB := -L$(topdir)/libcap -lpsx -lpthread
+
+ BUILD_GPERF := $(shell which gperf >/dev/null 2>/dev/null && echo yes)
+
+-SYSTEM_HEADERS = /usr/include
++LIBCAP_CPPFLAGS = -I$(KERNEL_HEADERS) -I$(topdir)/libcap/include $(DEFINES)
++CPPFLAGS += $(LIBCAP_CPPFLAGS)
++BUILD_CPPFLAGS += $(LIBCAP_CPPFLAGS)
+ INCS=$(topdir)/libcap/include/sys/capability.h
+ LDFLAGS += -L$(topdir)/libcap
+-CFLAGS += -Dlinux $(WARNINGS) $(DEBUG)
++CPPFLAGS += -Dlinux
++CFLAGS += $(WARNINGS) $(DEBUG)
+ PAM_CAP ?= $(shell if [ -f /usr/include/security/pam_modules.h ]; then echo yes ; else echo no ; fi)
+ INDENT := $(shell if [ -n "$$(which indent 2>/dev/null)" ]; then echo "| indent -kr" ; fi)
+ DYNAMIC := $(shell if [ ! -d "$(topdir)/.git" ]; then echo yes; fi)
+
+ GO := go
+-GOLANG := $(shell if [ -n "$(shell $(GO) version 2>/dev/null)" ]; then echo yes ; else echo no ; fi)
++GOLANG ?= $(shell if [ -n "$(shell $(GO) version 2>/dev/null)" ]; then echo yes ; else echo no ; fi)
+ ifeq ($(GOLANG),yes)
+ GOROOT := $(shell $(GO) env GOROOT)
+ GOCGO := $(shell if [ "$(shell $(GO) env CGO_ENABLED)" = 1 ]; then echo yes ; else echo no ; fi)
+diff --git a/Makefile b/Makefile
+index 03d7748..4437468 100644
+--- a/Makefile
++++ b/Makefile
+@@ -17,7 +17,6 @@ ifeq ($(GOLANG),yes)
+ $(MAKE) -C go $@
+ rm -f cap/go.sum
+ endif
+- $(MAKE) -C tests $@
+ $(MAKE) -C progs $@
+ $(MAKE) -C doc $@
+ $(MAKE) -C kdebug $@
+diff --git a/libcap/Makefile b/libcap/Makefile
+index 81b089e..63fe555 100644
+--- a/libcap/Makefile
++++ b/libcap/Makefile
+@@ -21,6 +21,7 @@ PSXOBJS=$(addsuffix .o, $(PSXFILES))
+ MAJLIBNAME=$(LIBNAME).$(VERSION)
+ MINLIBNAME=$(MAJLIBNAME).$(MINOR)
+ GPERF_OUTPUT = _caps_output.gperf
++CFLAGS += -fPIC
+
+ all: $(MINLIBNAME) $(STACAPLIBNAME) pcs $(STAPSXLIBNAME)
+
+@@ -50,7 +51,7 @@ libpsx.pc: libpsx.pc.in
+ $< >$@
+
+ _makenames: _makenames.c cap_names.list.h
+- $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
++ $(BUILD_CC) $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $< -o $@
+
+ cap_names.h: _makenames
+ ./_makenames > cap_names.h
+@@ -82,10 +83,10 @@ $(MINLIBNAME): $(CAPOBJS)
+ ln -sf $(MAJLIBNAME) $(LIBNAME)
+
+ %.o: %.c $(INCLS)
+- $(CC) $(CFLAGS) $(IPATH) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ cap_text.o: cap_text.c $(USE_GPERF_OUTPUT) $(INCLS)
+- $(CC) $(CFLAGS) $(IPATH) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
+
+ cap_test: cap_test.c libcap.h
+ $(CC) $(CFLAGS) $(IPATH) $< -o $@
+diff --git a/pam_cap/Makefile b/pam_cap/Makefile
+index 56604fd..2da4674 100644
+--- a/pam_cap/Makefile
++++ b/pam_cap/Makefile
+@@ -3,6 +3,8 @@
+ topdir=$(shell pwd)/..
+ include ../Make.Rules
+
++CFLAGS += -fPIC
++
+ all: pam_cap.so
+ $(MAKE) testlink
+
+@@ -16,16 +18,16 @@ install: all
+ # written (and you know why it fails), email me and explain why. Thanks!
+
+ pam_cap.so: pam_cap.o
+- $(LD) -o pam_cap.so $< $(LIBCAPLIB) $(LDFLAGS)
++ $(LD) $(CFLAGS) -o pam_cap.so $< $(LIBCAPLIB) $(LDFLAGS)
+
+ pam_cap.o: pam_cap.c
+- $(CC) $(CFLAGS) $(IPATH) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ test_pam_cap: test_pam_cap.c pam_cap.c
+ $(CC) $(CFLAGS) $(IPATH) -o $@ test_pam_cap.c $(LIBCAPLIB) $(LDFLAGS) --static
+
+ testlink: test.c pam_cap.o
+- $(CC) $(CFLAGS) -o $@ $+ -lpam -ldl $(LIBCAPLIB) $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) -o $@ $+ -lpam -ldl $(LIBCAPLIB) $(LDFLAGS)
+
+ test: pam_cap.so
+ make testlink
+diff --git a/progs/Makefile b/progs/Makefile
+index 076e44f..fd13351 100644
+--- a/progs/Makefile
++++ b/progs/Makefile
+@@ -23,7 +23,7 @@ $(BUILD): %: %.o $(DEPS)
+ $(CC) $(CFLAGS) -o $@ $< $(LIBCAPLIB) $(LDFLAGS)
+
+ %.o: %.c $(INCS)
+- $(CC) $(IPATH) $(CAPSH_SHELL) $(CFLAGS) -c $< -o $@
++ $(CC) $(CAPSH_SHELL) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ install: all
+ mkdir -p -m 0755 $(FAKEROOT)$(SBINDIR)
+diff --git a/tests/Makefile b/tests/Makefile
+index bfedbc2..2b9a801 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -16,19 +16,21 @@ test: run_psx_test run_libcap_psx_test
+
+ sudotest: test run_libcap_launch_test run_libcap_launch_test
+
++CFLAGS += -fPIC
++
+ install: all
+
+ run_psx_test: psx_test
+ ./psx_test
+
+ psx_test: psx_test.c $(DEPS)
+- $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBPSXLIB) -Wl,-wrap,pthread_create
++ $(CC) $(CFLAGS) $(CPPFLAGS) $< -o $@ $(LIBPSXLIB) -Wl,-wrap,pthread_create
+
+ run_libcap_psx_test: libcap_psx_test
+ ./libcap_psx_test
+
+ libcap_psx_test: libcap_psx_test.c $(DEPS)
+- $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create --static
++ $(CC) $(CFLAGS) $(CPPFLAGS) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create --static
+
+ run_libcap_launch_test: libcap_launch_test libcap_psx_launch_test noop
+ sudo ./libcap_launch_test
+--
+2.28.0
+