summaryrefslogtreecommitdiff
path: root/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild')
-rw-r--r--www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
new file mode 100644
index 000000000000..aff9792a698b
--- /dev/null
+++ b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
+HOMEPAGE="http://www.icinga.org/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-pnp.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-pnp"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ >=www-apps/icingaweb2-2.0.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/pnp"
+ doins -r "${S}"/*
+}