summaryrefslogtreecommitdiff
path: root/x11-misc/wayv/wayv-0.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/wayv/wayv-0.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/wayv/wayv-0.3-r2.ebuild')
-rw-r--r--x11-misc/wayv/wayv-0.3-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/wayv/wayv-0.3-r2.ebuild b/x11-misc/wayv/wayv-0.3-r2.ebuild
new file mode 100644
index 000000000000..dd82e5259727
--- /dev/null
+++ b/x11-misc/wayv/wayv-0.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Wayv is hand-writing/gesturing recognition software for X"
+HOMEPAGE="http://www.stressbunny.com/wayv"
+SRC_URI="http://www.stressbunny.com/gimme/wayv/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ sed -i -e 's| = -Wall -O2| += |g' src/Makefile* || die
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ cd doc
+ default
+ dodoc HOWTO*
+}