summaryrefslogtreecommitdiff
path: root/x11-misc/xcape/xcape-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
commitd83532aee7e94505bf23da29e6224ca164aac759 (patch)
treefcd6dbea91816dd541b6c602b5fed02ca574a5f6 /x11-misc/xcape/xcape-1.2-r1.ebuild
parenta2844b413d00a2859401e017a0311986151e1594 (diff)
gentoo auto-resync : 16:04:2023 - 17:51:01
Diffstat (limited to 'x11-misc/xcape/xcape-1.2-r1.ebuild')
-rw-r--r--x11-misc/xcape/xcape-1.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/xcape/xcape-1.2-r1.ebuild b/x11-misc/xcape/xcape-1.2-r1.ebuild
new file mode 100644
index 000000000000..8b524c8c6a55
--- /dev/null
+++ b/x11-misc/xcape/xcape-1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
+HOMEPAGE="https://github.com/alols/xcape"
+SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}