summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcube/wmcube-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /x11-plugins/wmcube/wmcube-1.0.2.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'x11-plugins/wmcube/wmcube-1.0.2.ebuild')
-rw-r--r--x11-plugins/wmcube/wmcube-1.0.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-plugins/wmcube/wmcube-1.0.2.ebuild b/x11-plugins/wmcube/wmcube-1.0.2.ebuild
index cca916b659af..1a9633dc99cc 100644
--- a/x11-plugins/wmcube/wmcube-1.0.2.ebuild
+++ b/x11-plugins/wmcube/wmcube-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,6 +26,13 @@ DOCS=(
)
S="${WORKDIR}/${P}/wmcube"
+src_prepare() {
+ default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
+}
+
src_compile() {
emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}