summaryrefslogtreecommitdiff
path: root/app-admin/entr/entr-5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/entr/entr-5.1.ebuild')
-rw-r--r--app-admin/entr/entr-5.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/entr/entr-5.1.ebuild b/app-admin/entr/entr-5.1.ebuild
new file mode 100644
index 000000000000..53c88c3095c2
--- /dev/null
+++ b/app-admin/entr/entr-5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="https://eradman.com/entrproject/"
+SRC_URI="https://eradman.com/entrproject/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ default
+}
+
+src_test() {
+ export CC="$(tc-getCC)"
+ default
+}