summaryrefslogtreecommitdiff
path: root/app-arch/upx/upx-4.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/upx/upx-4.0.1.ebuild')
-rw-r--r--app-arch/upx/upx-4.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-arch/upx/upx-4.0.1.ebuild b/app-arch/upx/upx-4.0.1.ebuild
new file mode 100644
index 000000000000..04a011030c35
--- /dev/null
+++ b/app-arch/upx/upx-4.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="https://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="!app-arch/upx-bin"
+BDEPEND="app-arch/xz-utils[extra-filters]"
+
+src_test() {
+ # Don't run tests in parallel, #878977
+ cmake_src_test -j1
+}