summaryrefslogtreecommitdiff
path: root/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild')
-rw-r--r--app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild b/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
new file mode 100644
index 000000000000..07b15f1f1e7e
--- /dev/null
+++ b/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="program for cryptanalyzing xor 'encryption' with variable key length"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=xor-analyze"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_compile() {
+ rm -f Makefile || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" xor-analyze xor-enc
+}
+
+src_install() {
+ dobin xor-analyze xor-enc
+ dosym xor-enc /usr/bin/xor-dec
+ dodoc README TODO
+}