summaryrefslogtreecommitdiff
path: root/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild
index 4e2874f98385..8647193f3913 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild
@@ -298,7 +298,9 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
local mingwcc=${CROSSCC:-$(usex x86 i686 x86_64)-w64-mingw32-gcc}
- : "${CROSSCFLAGS:=$(CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
+ : "${CROSSCFLAGS:=$(
+ filter-flags '-fstack-protector*' #870136
+ CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"