summaryrefslogtreecommitdiff
path: root/app-i18n/kinput2/kinput2-3.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/kinput2/kinput2-3.1-r2.ebuild')
-rw-r--r--app-i18n/kinput2/kinput2-3.1-r2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-i18n/kinput2/kinput2-3.1-r2.ebuild b/app-i18n/kinput2/kinput2-3.1-r2.ebuild
index 78b586f2ec09..2354479f0fd5 100644
--- a/app-i18n/kinput2/kinput2-3.1-r2.ebuild
+++ b/app-i18n/kinput2/kinput2-3.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -28,7 +28,7 @@ RDEPEND="x11-libs/libICE
freewnn? ( app-i18n/freewnn )"
DEPEND="${RDEPEND}
x11-misc/gccmakedep
- x11-misc/imake"
+ >=x11-misc/imake-1.0.8-r1"
S="${WORKDIR}/${MY_P}"
PATCHES=(
@@ -47,12 +47,15 @@ src_prepare() {
}
src_configure() {
- xmkmf -a || die
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
}
src_compile() {
emake \
+ AR="$(tc-getAR) cq" \
CC="$(tc-getCC)" \
+ RANLIB="$(tc-getRANLIB)" \
CDEBUGFLAGS="${CFLAGS}" \
LOCAL_LDFLAGS="${LDFLAGS}" \
XAPPLOADDIR="${EPREFIX}/usr/share/X11/app-defaults"