summaryrefslogtreecommitdiff
path: root/app-misc/icdiff/icdiff-1.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/icdiff/icdiff-1.9.1.ebuild')
-rw-r--r--app-misc/icdiff/icdiff-1.9.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/icdiff/icdiff-1.9.1.ebuild b/app-misc/icdiff/icdiff-1.9.1.ebuild
new file mode 100644
index 000000000000..eda476f4a614
--- /dev/null
+++ b/app-misc/icdiff/icdiff-1.9.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python2_7 python3_4 python3_5)
+
+inherit distutils-r1
+
+DESCRIPTION="Colourized diff that supports side-by-side diffing"
+HOMEPAGE="http://www.jefftk.com/icdiff"
+SRC_URI="https://github.com/jeffkaufman/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=(README.md ChangeLog)
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+python_test() {
+ ./test.sh "${EPYTHON%.*}" || die "Tests failed"
+}