summaryrefslogtreecommitdiff
path: root/app-misc/neofetch/neofetch-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/neofetch/neofetch-9999.ebuild')
-rw-r--r--app-misc/neofetch/neofetch-9999.ebuild19
1 files changed, 18 insertions, 1 deletions
diff --git a/app-misc/neofetch/neofetch-9999.ebuild b/app-misc/neofetch/neofetch-9999.ebuild
index 2b82020241d3..b5f654d39b3b 100644
--- a/app-misc/neofetch/neofetch-9999.ebuild
+++ b/app-misc/neofetch/neofetch-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit prefix
+
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~mips ~ppc64 ~x86"
@@ -26,3 +28,18 @@ RDEPEND="sys-apps/pciutils
x11-apps/xrandr
x11-apps/xwininfo
)"
+
+src_prepare() {
+ if use prefix; then
+ # bug #693526
+ hprefixify neofetch
+ sed -e "/has emerge/s:\${br_prefix}:${EPREFIX}:" -i neofetch \
+ || die "Failed to adjust for Prefix"
+ fi
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}