summaryrefslogtreecommitdiff
path: root/app-portage/elsw/elsw-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/elsw/elsw-9999.ebuild')
-rw-r--r--app-portage/elsw/elsw-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-portage/elsw/elsw-9999.ebuild b/app-portage/elsw/elsw-9999.ebuild
index bf24610ad3e1..f476f0d0e3b2 100644
--- a/app-portage/elsw/elsw-9999.ebuild
+++ b/app-portage/elsw/elsw-9999.ebuild
@@ -1,22 +1,24 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Tool providing a nice way to view the Portage world file"
HOMEPAGE="https://gitlab.com/xgqt/python-elsw/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://gitlab.com/xgqt/python-${PN}.git"
else
inherit pypi
- KEYWORDS="~amd64 ~x86"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi
LICENSE="GPL-2+"