summaryrefslogtreecommitdiff
path: root/app-portage/golop/golop-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/golop/golop-9999.ebuild')
-rw-r--r--app-portage/golop/golop-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-portage/golop/golop-9999.ebuild b/app-portage/golop/golop-9999.ebuild
index 9e60869091a0..461b2e016c8d 100644
--- a/app-portage/golop/golop-9999.ebuild
+++ b/app-portage/golop/golop-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -12,7 +12,7 @@ else
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
inherit golang-vcs-snapshot
fi
-inherit golang-build
+inherit golang-build prefix
DESCRIPTION="A pure Go re-implementation of genlop"
HOMEPAGE="https://github.com/klausman/golop"
@@ -22,6 +22,11 @@ IUSE=""
DEPEND=""
RDEPEND=""
+src_prepare() {
+ sed -i -e 's@/var/log/emerge.log@'"${EPREFIX}"'&@g' src/github.com/klausman/golop/main.go || die
+ default
+}
+
src_install() {
dobin ${PN}