summaryrefslogtreecommitdiff
path: root/app-text/libepubgen/libepubgen-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libepubgen/libepubgen-0.1.0.ebuild')
-rw-r--r--app-text/libepubgen/libepubgen-0.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/libepubgen/libepubgen-0.1.0.ebuild b/app-text/libepubgen/libepubgen-0.1.0.ebuild
new file mode 100644
index 000000000000..508558384209
--- /dev/null
+++ b/app-text/libepubgen/libepubgen-0.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EPUB generator for librevenge"
+HOMEPAGE="https://sourceforge.net/projects/libepubgen/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-weffc \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}