summaryrefslogtreecommitdiff
path: root/app-text/manpager/manpager-1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/manpager/manpager-1.ebuild')
-rw-r--r--app-text/manpager/manpager-1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/manpager/manpager-1.ebuild b/app-text/manpager/manpager-1.ebuild
new file mode 100644
index 000000000000..39b1214d8e0d
--- /dev/null
+++ b/app-text/manpager/manpager-1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Enable colorization of man pages"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE=""
+
+S=${WORKDIR}
+
+src_compile() {
+ local cmd=(
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}
+ "${FILESDIR}"/manpager.c -o ${PN}
+ )
+ echo "${cmd[@]}"
+ "${cmd[@]}" || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/env.d
+ echo "MANPAGER=manpager" | newins - 00manpager
+}