summaryrefslogtreecommitdiff
path: root/app-text/pdfminer/pdfminer-20140328.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfminer/pdfminer-20140328.ebuild')
-rw-r--r--app-text/pdfminer/pdfminer-20140328.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/pdfminer/pdfminer-20140328.ebuild b/app-text/pdfminer/pdfminer-20140328.ebuild
new file mode 100644
index 000000000000..3f0dbf03188c
--- /dev/null
+++ b/app-text/pdfminer/pdfminer-20140328.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool for extracting information from PDF documents"
+HOMEPAGE="http://www.unixuser.org/~euske/python/pdfminer/ https://pypi.org/project/pdfminer/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+python_compile_all(){
+ use examples && emake -C samples all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}