summaryrefslogtreecommitdiff
path: root/app-vim/alternate
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/alternate')
-rw-r--r--app-vim/alternate/Manifest1
-rw-r--r--app-vim/alternate/alternate-2.18-r3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/alternate/Manifest b/app-vim/alternate/Manifest
index 2850778e7979..5465528de0bb 100644
--- a/app-vim/alternate/Manifest
+++ b/app-vim/alternate/Manifest
@@ -2,4 +2,5 @@ AUX alternate-2.18-hh-cc-alternation.patch 918 BLAKE2B 0362420f64fdd1607529842d9
DIST alternate-2.18.tar.gz 8652 BLAKE2B f6e50d3e1499fb913f7cfa4ff95df180855c7857a700428be1339916aed4513bf77a8da62b75407a6c129f4da3e3bcd00f5caed53d7a939a2eac96a287a11ffe SHA512 d797b99cbe536285d87c5bb14adfcaa3e18611351c8529d9a0755606e766ecc006f19af5cd9b9535f236220dc525bbc27e1280cbb1e3c71f7444cdefd506cefa
DIST alternate.txt 8897 BLAKE2B b2c2ad9e39c98c82592034ddb0db79803f39bdf3c8d55307aecc488855a75c7be508b41a6a6cf9d3f3d0f4e938feb65fdd756040d8e51e0244c9dc6b9fbacd86 SHA512 92b24aef5fe1fb459b4cb85ca780ae20126bc79138ac15dec652c15a89b688d40bedc00bdae8fce912c8805b24b8805e45ddbd9e6b1ec10c20e61eed11d37651
EBUILD alternate-2.18-r2.ebuild 995 BLAKE2B 96fdeff6a4d502b7c368643cdc3fd8388892003613908f7408b3cc8be896bba3911cd0e129b82006c678c1fb162dd6d197ebc67252d856e9f1cf59142319b720 SHA512 2f4e22cc32f3c1cb80edebcfebef3db3d133bb5f451e043d3d9c25d83f14b579883d0a408486d691d3ce0d4f6f10f54b2e96980c8a585f6226056ca6e66eb365
+EBUILD alternate-2.18-r3.ebuild 1000 BLAKE2B 9cca092871ee1e67a0175d6f89a5d014b58f124133b81de2d9f1766e9ed318933018a0c59fe8de021e3583d1468b09871ef1035ceb56a101f8aa5cdd0a658774 SHA512 48d3dd18a4e3c161971264f93bcc24774a6c8f39bf0b49bdc3ed8e35ee6693e8cac16efe339f0a1309bd9c1a405578a74682d62ee9fdc16d205537fe3b4d7c32
MISC metadata.xml 332 BLAKE2B c54e6ef20fbf88e7ce67a793b3914a64dbd291129c186527a23412941ad882e492a4b10692bbacdc8b1718b15ce53e31057cf1237d264ba9259105143fb24468 SHA512 0e9f477bc091e9be6585d40eb298f24cba09b8adbf742915dc56ebe779c62863168327163004e462c5b0259cc6f0deef26d6a1c78d39d87f081845e3692bcbf5
diff --git a/app-vim/alternate/alternate-2.18-r3.ebuild b/app-vim/alternate/alternate-2.18-r3.ebuild
new file mode 100644
index 000000000000..7588fe2d8ab9
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="
+ https://github.com/vim-scripts/a.vim
+ https://www.vim.org/scripts/script.php?script_id=31"
+SRC_URI="
+ https://github.com/vim-scripts/a.vim/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://www.vim.org/scripts/download_script.php?src_id=6347 -> ${PN}.txt"
+S="${WORKDIR}/a.vim-${PV}"
+
+LICENSE="alternate"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hh-cc-alternation.patch
+)
+
+src_prepare() {
+ default
+ mkdir -p "${S}/doc" || die
+ cp "${DISTDIR}/${PN}.txt" "${S}/doc" || die
+}