summaryrefslogtreecommitdiff
path: root/app-vim/ctx/ctx-1.17-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/ctx/ctx-1.17-r2.ebuild')
-rw-r--r--app-vim/ctx/ctx-1.17-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/ctx/ctx-1.17-r2.ebuild b/app-vim/ctx/ctx-1.17-r2.ebuild
new file mode 100644
index 000000000000..8f6db1d5e1bd
--- /dev/null
+++ b/app-vim/ctx/ctx-1.17-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: display current scope context in a C file"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=208"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+
+VIM_PLUGIN_HELPURI="https://www.vim.org/scripts/script.php?script_id=208"
+
+# bug #74897
+RDEPEND="!app-vim/enhancedcommentify"
+
+# See bug 591068.
+DEPEND="app-editors/vim[perl]"