summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin12561 -> 12909 bytes
-rw-r--r--dev-cpp/jarowinkler-cpp/Manifest3
-rw-r--r--dev-cpp/jarowinkler-cpp/jarowinkler-cpp-1.0.2.ebuild32
-rw-r--r--dev-cpp/jarowinkler-cpp/metadata.xml11
-rw-r--r--dev-cpp/rapidfuzz-cpp/Manifest3
-rw-r--r--dev-cpp/rapidfuzz-cpp/metadata.xml11
-rw-r--r--dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild42
7 files changed, 102 insertions, 0 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index 43ba86e26463..041e46c8ce9f 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/jarowinkler-cpp/Manifest b/dev-cpp/jarowinkler-cpp/Manifest
new file mode 100644
index 000000000000..cdae75728102
--- /dev/null
+++ b/dev-cpp/jarowinkler-cpp/Manifest
@@ -0,0 +1,3 @@
+DIST jarowinkler-cpp-1.0.2.gh.tar.gz 10375 BLAKE2B e55f6e72ea66e553c047bfd2df8d4337430292391138595cd148686bc79a326e195cd55d81fe3b46aa41e7a852c0ea8bfb5891e6207ed3af538eea7597accd5a SHA512 8eeae55ff64dcc434dd8f8d33c03c9b9c828f54cd6a6a028e376763036e445fa6db81b5a9a19d84d023c6bf3968223c3f9a9e4220feb6f537e9c1b2c4f21cb11
+EBUILD jarowinkler-cpp-1.0.2.ebuild 569 BLAKE2B 99e0c790bee9d57e25846feea59706173c150f6a105113e06472ddd186a4fcc78d3c9688549fa528a72852eb5524a17fca0d07ed6bdc2e3f38600fe7e0f0e203 SHA512 124ac77c53a7d0d62f2a62447b463237a9a3a627aa89128627f545da0e5db564864ad8c1f92a3aa480f5dace49462d48eb4ff1f61a2977df8a9135affd86a802
+MISC metadata.xml 340 BLAKE2B d2d874a171c2e5170d48a31e0d95110996d73f566f19bc9f4aaca9094d996e206d29266a4083f9a74673c5399ed8a5294d293ae498046dd61c8ccbe08249f2c6 SHA512 d9feb8a9e4328e16a25d83164516a7a4f271bf81a07e375f6906e7f18773663106d0fcd8cf16759b3b73a75486ca989210d4951e093c4ad95b82012921c76f58
diff --git a/dev-cpp/jarowinkler-cpp/jarowinkler-cpp-1.0.2.ebuild b/dev-cpp/jarowinkler-cpp/jarowinkler-cpp-1.0.2.ebuild
new file mode 100644
index 000000000000..43f5ed39f112
--- /dev/null
+++ b/dev-cpp/jarowinkler-cpp/jarowinkler-cpp-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Fast Jaro and Jaro Winkler distance"
+HOMEPAGE="https://github.com/maxbachmann/jarowinkler-cpp/"
+SRC_URI="
+ https://github.com/maxbachmann/jarowinkler-cpp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ >=dev-cpp/catch-3
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DJARO_WINKLER_BUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/dev-cpp/jarowinkler-cpp/metadata.xml b/dev-cpp/jarowinkler-cpp/metadata.xml
new file mode 100644
index 000000000000..8006795ac5b2
--- /dev/null
+++ b/dev-cpp/jarowinkler-cpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">maxbachmann/jarowinkler-cpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/rapidfuzz-cpp/Manifest b/dev-cpp/rapidfuzz-cpp/Manifest
new file mode 100644
index 000000000000..afac94827977
--- /dev/null
+++ b/dev-cpp/rapidfuzz-cpp/Manifest
@@ -0,0 +1,3 @@
+DIST rapidfuzz-cpp-1.6.0.gh.tar.gz 250024 BLAKE2B 96d70680bb9b3c3e053b385845b543f69bb4215c6be92df6b7e61559cfa0f072833a13ceadf24f73531e848517864461cd696504584ea3a489d37e56c0a03c3b SHA512 ba319af67428a96df406b10b11eafa4c73762f0916d2ac4ac2860f1a25a97fc9e4e3a69c8633c8fed8ef76a0c4a8e073bc16048bde111782d0e8f00e396a4df9
+EBUILD rapidfuzz-cpp-1.6.0.ebuild 825 BLAKE2B b4323c2873210fe0bd3ed5fdd79d45fa552f2e9c48bea3144c98dc4a2e9cc52119b4b16926d08a8a12d0c92f89d2598662da22a4d4130192e5c40958e9000289 SHA512 bcb6ff63843c3e50ad6c80cee4b2c94a98c96946fee0970ca1997a1185c0587e5f87e88c6051803813791f1f9537f9e4927f3903e5974954b1485939c4198998
+MISC metadata.xml 338 BLAKE2B 43c0cb99a03961ca48146b237a22fbf56c90312b7a39b57a3d01dd532f4f01891e713c802b372b4efb0af528198d8f2c0febae6ffec65da152e8e23f7a67b8a4 SHA512 a54d78c951d15319a2e467dc5d5692d9af5ef9e79c9c9135ee5e26853361ec6bcfebab8e82e3299314f9b7c8cd703365ff6d144e7e6876f486ca5f3a02a3b0f7
diff --git a/dev-cpp/rapidfuzz-cpp/metadata.xml b/dev-cpp/rapidfuzz-cpp/metadata.xml
new file mode 100644
index 000000000000..b69c1750aa36
--- /dev/null
+++ b/dev-cpp/rapidfuzz-cpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">maxbachmann/rapidfuzz-cpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild
new file mode 100644
index 000000000000..99e66055cc0f
--- /dev/null
+++ b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Rapid fuzzy string matching in C++"
+HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/"
+SRC_URI="
+ https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ >=dev-cpp/catch-3
+ )
+"
+
+src_prepare() {
+ # apparently "C++ best practices" don't mind fetching random stuff
+ # at build time
+ sed -i -e '/aminya/,/^)/d' test/CMakeLists.txt || die
+ find -name 'CMakeLists.txt' -exec \
+ sed -i -e 's:project_warnings::' {} + || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}