summaryrefslogtreecommitdiff
path: root/dev-db/postgresql/postgresql-9.6.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-9.6.22.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9.6.22.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-db/postgresql/postgresql-9.6.22.ebuild b/dev-db/postgresql/postgresql-9.6.22.ebuild
index 81db6bcb3596..6ef13fcda3a7 100644
--- a/dev-db/postgresql/postgresql-9.6.22.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.22.ebuild
@@ -411,7 +411,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi