summaryrefslogtreecommitdiff
path: root/dev-haskell/binary-tagged/binary-tagged-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/binary-tagged/binary-tagged-0.2.ebuild')
-rw-r--r--dev-haskell/binary-tagged/binary-tagged-0.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/binary-tagged/binary-tagged-0.2.ebuild b/dev-haskell/binary-tagged/binary-tagged-0.2.ebuild
new file mode 100644
index 000000000000..f53ead554f72
--- /dev/null
+++ b/dev-haskell/binary-tagged/binary-tagged-0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Tagged binary serialisation"
+HOMEPAGE="https://github.com/phadej/binary-tagged#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?] <dev-haskell/aeson-1.5:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1.1.6:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/cryptohash-sha1-0.11.100.1:=[profile?] <dev-haskell/cryptohash-sha1-0.12:=[profile?]
+ >=dev-haskell/generics-sop-0.3.2.0:=[profile?] <dev-haskell/generics-sop-0.6:=[profile?]
+ >=dev-haskell/hashable-1.2:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.18.5:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( dev-haskell/bifunctors
+ >=dev-haskell/binary-instances-1 <dev-haskell/binary-instances-1.1
+ dev-haskell/quickcheck-instances
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >=4.7.0.2 && <4.13' 'base >=4.7.0.2' \
+ 'time >=1.4.2 && <1.9' 'time >=1.4.2'
+}