summaryrefslogtreecommitdiff
path: root/dev-haskell/blaze-markup/blaze-markup-0.8.2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/blaze-markup/blaze-markup-0.8.2.4.ebuild')
-rw-r--r--dev-haskell/blaze-markup/blaze-markup-0.8.2.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/blaze-markup/blaze-markup-0.8.2.4.ebuild b/dev-haskell/blaze-markup/blaze-markup-0.8.2.4.ebuild
new file mode 100644
index 000000000000..4de88dc0c818
--- /dev/null
+++ b/dev-haskell/blaze-markup/blaze-markup-0.8.2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A blazingly fast markup combinator library for Haskell"
+HOMEPAGE="http://jaspervdj.be/blaze"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
+ >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-1.0 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4 && < 4.14' 'base >= 4'
+}