summaryrefslogtreecommitdiff
path: root/dev-haskell/hstringtemplate/hstringtemplate-0.8.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hstringtemplate/hstringtemplate-0.8.5.ebuild')
-rw-r--r--dev-haskell/hstringtemplate/hstringtemplate-0.8.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/hstringtemplate/hstringtemplate-0.8.5.ebuild b/dev-haskell/hstringtemplate/hstringtemplate-0.8.5.ebuild
new file mode 100644
index 000000000000..a419075b977f
--- /dev/null
+++ b/dev-haskell/hstringtemplate/hstringtemplate-0.8.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HStringTemplate"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="StringTemplate implementation in Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/HStringTemplate"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ <dev-haskell/parsec-4:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/void:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+S="${WORKDIR}/${MY_P}"