summaryrefslogtreecommitdiff
path: root/dev-haskell/strict/strict-0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/strict/strict-0.5.ebuild')
-rw-r--r--dev-haskell/strict/strict-0.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/strict/strict-0.5.ebuild b/dev-haskell/strict/strict-0.5.ebuild
new file mode 100644
index 000000000000..eebc629b95ad
--- /dev/null
+++ b/dev-haskell/strict/strict-0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+#hackport: flags: +assoc
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Strict data types and String IO"
+HOMEPAGE="https://github.com/haskell-strict/strict"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/assoc-1.1:=[profile?] <dev-haskell/assoc-1.2:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/these-1.2:=[profile?] <dev-haskell/these-1.3:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ || (
+ ( >=dev-haskell/text-1.2.3.0 <dev-haskell/text-1.3 )
+ ( >=dev-haskell/text-2.0 <dev-haskell/text-2.1 )
+ )
+ dev-haskell/text:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=assoc
+}