summaryrefslogtreecommitdiff
path: root/dev-haskell/system-filepath
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/system-filepath')
-rw-r--r--dev-haskell/system-filepath/Manifest5
-rw-r--r--dev-haskell/system-filepath/metadata.xml14
-rw-r--r--dev-haskell/system-filepath/system-filepath-0.4.13.4.ebuild28
-rw-r--r--dev-haskell/system-filepath/system-filepath-0.4.8-r1.ebuild31
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-haskell/system-filepath/Manifest b/dev-haskell/system-filepath/Manifest
new file mode 100644
index 000000000000..0ca872eee243
--- /dev/null
+++ b/dev-haskell/system-filepath/Manifest
@@ -0,0 +1,5 @@
+DIST system-filepath-0.4.13.4.tar.gz 16590 BLAKE2B de9203bb34bb885a9b08fa7fa3f5ac977698fd9edf6af9ebb4db512e04ea352d1770ce1ea75f80da546dac707d4627d940f176177eac497b74d47f7e5dc07696 SHA512 81df3ed7bee9ae8b568533361d1b6574cc26c24218922005f03d70828624b6fd279342753c571921c62f69b6dadce4eb6c88cf4ef5cb76c536c5113c37f5cc38
+DIST system-filepath-0.4.8.tar.gz 14497 BLAKE2B 4e61d45f384043da31b32b64eaa522274da66801c13bd81370cdd777b18861b2812e297766252acae43aac36e7bcf82b53061609d9f457853d8c1730b8591edc SHA512 ee23a468186f1e709ec8b39d3b6855038a9f5a7fa4b37b37407b8dbed7668ddb4efe21e877a51b94b20bc3d9a59dd9a525b7378783ac9a0c7a4183ba615b01be
+EBUILD system-filepath-0.4.13.4.ebuild 793 BLAKE2B fa889cc00510dde31e81bf837b4d8bd81d0af24d02273c9186d3d85061e1c82e1b372bf314a73c8afa82569236bafd91e4dd66ce9464d1fac2a23d7fbc0a9ef8 SHA512 0cac52fa99040d8bd45cd2245dad26c51b5c7e9f0d6fd3f20ae066ffda22e67d0890480ebe00e500f2fc5e64708cf4a4be6999456c837046f3448c6060b69428
+EBUILD system-filepath-0.4.8-r1.ebuild 752 BLAKE2B d7ad96ffe5f78fce880ab7f37cc32a34fb296fae0cdda0bc1eff6033c42f55efe41117cac2e52b7a2671a12a4280db6cc96e9f81ecf275a992bd8aa8c63080ea SHA512 a3388a0e0d4c765a0b2d8d8cbe4fe6d6c8b8a0337e723d4f51120f5a1273ce23747537fabef2361bc117debf1177f626e48223859b2fe224dfe6770a75fc6434
+MISC metadata.xml 439 BLAKE2B 4862fbaedc30b3a4520e630d113066e30c1233392789b97d0697891b8f4985c8679efed8dc515b8839126be02b3a3d17a702e4b6f2faaf01ac012b335286565d SHA512 85d9affd4354d2c9409400e6f9213b0e81c74ea4388b39c8893f588fdb3215016f0f3fc9ecb751bf45ebd8f3582b0327a25fc3cf92276b1a86e9c5479059a073
diff --git a/dev-haskell/system-filepath/metadata.xml b/dev-haskell/system-filepath/metadata.xml
new file mode 100644
index 000000000000..ffc4e58c8540
--- /dev/null
+++ b/dev-haskell/system-filepath/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ High-level, byte-based file and directory path manipulations
+ </longdescription>
+ <upstream>
+ <remote-id type="github">fpco/haskell-filesystem</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/system-filepath/system-filepath-0.4.13.4.ebuild b/dev-haskell/system-filepath/system-filepath-0.4.13.4.ebuild
new file mode 100644
index 000000000000..3d0d0019fec0
--- /dev/null
+++ b/dev-haskell/system-filepath/system-filepath-0.4.13.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="High-level, byte-based file and directory path manipulations (deprecated)"
+HOMEPAGE="https://github.com/fpco/haskell-filesystem"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-0.11.0.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.4 <dev-haskell/chell-0.5
+ >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3
+ dev-haskell/quickcheck )
+"
diff --git a/dev-haskell/system-filepath/system-filepath-0.4.8-r1.ebuild b/dev-haskell/system-filepath/system-filepath-0.4.8-r1.ebuild
new file mode 100644
index 000000000000..bc94e91e535b
--- /dev/null
+++ b/dev-haskell/system-filepath/system-filepath-0.4.8-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="High-level, byte-based file and directory path manipulations"
+HOMEPAGE="https://john-millikin.com/software/haskell-filesystem/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/text-0.7.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'deepseq >= 1.1 && < 1.4' 'deepseq >= 1.1' \
+ 'text >= 0.7.1 && < 0.12' 'text >= 0.7.1'
+}