summaryrefslogtreecommitdiff
path: root/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/eclipsito/eclipsito-0_pre20130713.ebuild')
-rw-r--r--dev-java/eclipsito/eclipsito-0_pre20130713.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild b/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild
new file mode 100644
index 000000000000..6625ce2e9267
--- /dev/null
+++ b/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A small subset of Eclipse core libraries for modular applications"
+HOMEPAGE="https://code.google.com/p/eclipsito/"
+SRC_URI="https://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}/org.bardsoftware.${PN}"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-build.xml
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc apidocs
+ use source && java-pkg_dosrc src/
+}