summaryrefslogtreecommitdiff
path: root/dev-lang/nprolog/nprolog-3.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nprolog/nprolog-3.22.ebuild')
-rw-r--r--dev-lang/nprolog/nprolog-3.22.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/nprolog/nprolog-3.22.ebuild b/dev-lang/nprolog/nprolog-3.22.ebuild
new file mode 100644
index 000000000000..40d3b000da40
--- /dev/null
+++ b/dev-lang/nprolog/nprolog-3.22.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler to be compatible with Arity/Prolog32"
+HOMEPAGE="https://github.com/sasagawa888/nprolog/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
+else
+ SRC_URI="https://github.com/sasagawa888/nprolog/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+DOCS=( README{,-ja}.md document )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe npl
+
+ insinto "/usr/share/${PN}"
+ doins -r example library
+
+ einstalldocs
+}