summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.6.12-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.6.12-r1.ebuild')
-rw-r--r--dev-lang/python/python-3.6.12-r1.ebuild35
1 files changed, 1 insertions, 34 deletions
diff --git a/dev-lang/python/python-3.6.12-r1.ebuild b/dev-lang/python/python-3.6.12-r1.ebuild
index 1695164047aa..d810a677d0fd 100644
--- a/dev-lang/python/python-3.6.12-r1.ebuild
+++ b/dev-lang/python/python-3.6.12-r1.ebuild
@@ -55,8 +55,8 @@ DEPEND="${RDEPEND}
test? ( app-arch/xz-utils[extra-filters(+)] )
virtual/pkgconfig
!sys-devel/gcc[libffi(-)]"
+PDEPEND="app-eselect/eselect-python"
RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1"
src_prepare() {
# Ensure that internal copies of expat, libffi and zlib are not used.
@@ -330,36 +330,3 @@ src_install() {
"${scriptdir}/idle" || die
fi
}
-
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${PYVER}" && ! has_version ">=${CATEGORY}/${PN}-${PYVER}_alpha"; then
- python_updater_warning="1"
- fi
-}
-
-eselect_python_update() {
- if [[ -z "$(eselect python show)" || \
- ! -f "${EROOT}/usr/bin/$(eselect python show)" ]]; then
- eselect python update
- fi
-
- if [[ -z "$(eselect python show --python${PV%%.*})" || \
- ! -f "${EROOT}/usr/bin/$(eselect python show --python${PV%%.*})" ]]
- then
- eselect python update --python${PV%%.*}
- fi
-}
-
-pkg_postinst() {
- eselect_python_update
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn "You have just upgraded from an older version of Python."
- ewarn
- ewarn "Please adjust PYTHON_TARGETS (if so desired), and run emerge with the --newuse or --changed-use option to rebuild packages installing python modules."
- fi
-}
-
-pkg_postrm() {
- eselect_python_update
-}