summaryrefslogtreecommitdiff
path: root/dev-libs/FP16/FP16-2021.03.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/FP16/FP16-2021.03.20.ebuild')
-rw-r--r--dev-libs/FP16/FP16-2021.03.20.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/FP16/FP16-2021.03.20.ebuild b/dev-libs/FP16/FP16-2021.03.20.ebuild
new file mode 100644
index 000000000000..160c3c91f429
--- /dev/null
+++ b/dev-libs/FP16/FP16-2021.03.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+CommitId=0a92994d729ff76a58f692d3028ca1b64b145d91
+DESCRIPTION="conversion to/from half-precision floating point formats"
+HOMEPAGE="https://github.com/Maratyszcza/FP16/"
+SRC_URI="https://github.com/Maratyszcza/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-libs/psimd"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DFP16_BUILD_BENCHMARKS=OFF
+ -DFP16_BUILD_TESTS=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}