summaryrefslogtreecommitdiff
path: root/dev-libs/capstone/files/capstone-9999-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/capstone/files/capstone-9999-werror.patch')
-rw-r--r--dev-libs/capstone/files/capstone-9999-werror.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-libs/capstone/files/capstone-9999-werror.patch b/dev-libs/capstone/files/capstone-9999-werror.patch
new file mode 100644
index 000000000000..1ec58fa056a3
--- /dev/null
+++ b/dev-libs/capstone/files/capstone-9999-werror.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/911481
+Upstream: https://github.com/capstone-engine/capstone/pull/2114
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ project(capstone
+ if (MSVC)
+ add_compile_options(/W1 /w14189)
+ else()
+- add_compile_options(-Werror -Wformat -Wmissing-braces -Wunused-function -Warray-bounds -Wunused-variable -Wparentheses -Wint-in-bool-context)
++ add_compile_options(-Wformat -Wmissing-braces -Wunused-function -Warray-bounds -Wunused-variable -Wparentheses -Wint-in-bool-context)
+ endif()
+
+