summaryrefslogtreecommitdiff
path: root/dev-libs/distorm3/distorm3-3.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/distorm3/distorm3-3.5.2.ebuild')
-rw-r--r--dev-libs/distorm3/distorm3-3.5.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/distorm3/distorm3-3.5.2.ebuild b/dev-libs/distorm3/distorm3-3.5.2.ebuild
new file mode 100644
index 000000000000..ca0ec447e8d4
--- /dev/null
+++ b/dev-libs/distorm3/distorm3-3.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+DEPEND=""
+RDEPEND=""
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_install() {
+ distutils-r1_python_install
+
+ # don't know why it does not happen by default
+ python_optimize
+}