summaryrefslogtreecommitdiff
path: root/dev-libs/libevent/libevent-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libevent/libevent-9999.ebuild')
-rw-r--r--dev-libs/libevent/libevent-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/libevent/libevent-9999.ebuild b/dev-libs/libevent/libevent-9999.ebuild
index 06fa234e5ef5..16a0b3af8b69 100644
--- a/dev-libs/libevent/libevent-9999.ebuild
+++ b/dev-libs/libevent/libevent-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils git-r3 multilib-minimal
+EAPI=7
+inherit autotools git-r3 multilib-minimal
DESCRIPTION="Library to execute a function when a specific event occurs on a file descriptor"
EGIT_REPO_URI="https://github.com/libevent/libevent"
@@ -20,7 +20,7 @@ RESTRICT="test"
DEPEND="
ssl? (
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
)
"
RDEPEND="
@@ -57,5 +57,5 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}