summaryrefslogtreecommitdiff
path: root/dev-libs/libgit2/libgit2-0.28.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgit2/libgit2-0.28.4.ebuild')
-rw-r--r--dev-libs/libgit2/libgit2-0.28.4.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-libs/libgit2/libgit2-0.28.4.ebuild b/dev-libs/libgit2/libgit2-0.28.4.ebuild
index 84b9ad2b9c54..fe94903c855e 100644
--- a/dev-libs/libgit2/libgit2-0.28.4.ebuild
+++ b/dev-libs/libgit2/libgit2-0.28.4.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils python-any-r1
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+inherit cmake python-any-r1
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ~ppc x86 ~ppc-macos"
+ KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86 ~ppc-macos"
fi
DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.github.com/"
+HOMEPAGE="https://libgit2.org"
LICENSE="GPL-2-with-linking-exception"
SLOT="0/28"
@@ -46,7 +46,7 @@ src_configure() {
-DUSE_SSH=$(usex ssh)
-DTHREADSAFE=$(usex threads)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -56,12 +56,12 @@ src_test() {
ewarn "Skipping tests: non-root privileges are required for all tests to pass"
else
local TEST_VERBOSE=1
- cmake-utils_src_test -R offline
+ cmake_src_test -R offline
fi
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc docs/*.{md,txt}
if use examples ; then