summaryrefslogtreecommitdiff
path: root/dev-libs/sdformat
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/sdformat')
-rw-r--r--dev-libs/sdformat/Manifest5
-rw-r--r--dev-libs/sdformat/files/ruby.patch31
-rw-r--r--dev-libs/sdformat/sdformat-9.10.0.ebuild (renamed from dev-libs/sdformat/sdformat-9.8.0.ebuild)3
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-libs/sdformat/Manifest b/dev-libs/sdformat/Manifest
index d93758b2d8cc..40f6be1e2ee4 100644
--- a/dev-libs/sdformat/Manifest
+++ b/dev-libs/sdformat/Manifest
@@ -1,3 +1,4 @@
-DIST sdformat-9.8.0.tar.bz2 706107 BLAKE2B d4880b8b26bc792f7932f92238fea9e583284fb95fd139da2755590f795bf8f00d2087b949ff44df7c04f7e3e81218f7a7f5643c65164e7805b76626ac13de4b SHA512 090e654f442c26d0a930960fa603ab5e58a28d8cef276ea75f4f63cad29c249c90045e76a2e081b2f90bc569b80abee086efe7598c138fd81b387535debf7e6c
-EBUILD sdformat-9.8.0.ebuild 808 BLAKE2B 00efeb0f8266d762d3d509d5d3b2257117dc7757e788218e30f8096fdcce3ff57da627e90e75b09d8f2bb41f51d236b147083cdf5149ff708e4680ab441a992a SHA512 fcbc2147f6b49eb76016029d7fff1ad1a6c77f16d31cd5592b46c18e143ff518027ac257dd8a3a7ec0813a32c137a438b6f5020d1a7d44680b0418fa1ced0330
+AUX ruby.patch 775 BLAKE2B 48ffc270e77fcb4cd6d41c31007fa36761d662f238d3789b143a92a24a1d516b17d66b13af9c86f3c667c356f2f61438545a42fe719a5b5b72049c9555c3156d SHA512 7a8f5b6caec50dc2833de6efd84b67daa5feea1607390935fddaee83565ee51e1081a832479bd706bbebbfa7e6a8945cd24f1ddb01c0b8d30ed94f6d77b81bc1
+DIST sdformat-9.10.0.tar.bz2 709883 BLAKE2B 3f79ad7d13cc3e2b4e4ee7b2dfc5819e805ccbae7678e4ea4d4e2577845ddc3bc69c15043132de989ac286642757bcf0c1d66990fddbc3b61aa1a297c78b7682 SHA512 233305adc98a57eef360200d651bf0951229b12383e49496e05989ce165d88d4fd86c40819a6b6528125fe0185157d26b5712880332971d8bd2fd1f7daa4c6e8
+EBUILD sdformat-9.10.0.ebuild 845 BLAKE2B 740dd09c8be02e1e0df9bc2766490fd8de4682aadb4e157825474bc7727af94e689e339d8395126b5e3557fbe428b3071dfbd4a852b299096b1d9b59fba7cda6 SHA512 7b144b19dd7e695694d46c5e72a5621ab529e97a11c3bb26afac04e7cf0193230730385db482da6daa032a14601e3cdfb1e141112148b88229cc2ddfcc9cae53
MISC metadata.xml 244 BLAKE2B 5a5426f4a80c61e49915e23ab7298bd1e53d89bd5361ad61fdaa3a50c88e7f27ea69205fd8c407addfdfde991e10cbe70aa554bfd737daf9d3d639c4eddd5934 SHA512 052b13f84da2d92069cdab006492e4b72274519bae5081f01ee4605215c7dca16bade6fa3856a7fec9435d1b564e607c9c52e0f9fdf199363af330778bf6c0af
diff --git a/dev-libs/sdformat/files/ruby.patch b/dev-libs/sdformat/files/ruby.patch
new file mode 100644
index 000000000000..ceada099cfe3
--- /dev/null
+++ b/dev-libs/sdformat/files/ruby.patch
@@ -0,0 +1,31 @@
+Index: sdformat-9.10.0/tools/xmlschema.rb
+===================================================================
+--- sdformat-9.10.0.orig/tools/xmlschema.rb
++++ sdformat-9.10.0/tools/xmlschema.rb
+@@ -265,7 +265,7 @@ opt_parser.parse!
+ if infile.nil?
+ puts "Missing option -i."
+ exit
+-elsif !File.exists?(infile)
++elsif !File.exist?(infile)
+ puts "Input file[#{infile}] does not exist\n"
+ exit
+ end
+@@ -273,7 +273,7 @@ end
+ if $path.nil?
+ puts "Missing option -s."
+ exit
+-elsif !Dir.exists?($path)
++elsif !Dir.exist?($path)
+ puts "SDF source dir[#{$path}] does not exist\n"
+ exit
+ end
+@@ -281,7 +281,7 @@ end
+ if outdir.nil?
+ puts "Missing output directory, option -o."
+ exit
+-elsif !Dir.exists?(outdir)
++elsif !Dir.exist?(outdir)
+ Dir.mkdir(outdir)
+ end
+
diff --git a/dev-libs/sdformat/sdformat-9.8.0.ebuild b/dev-libs/sdformat/sdformat-9.10.0.ebuild
index 4a78444096c6..210757ba03de 100644
--- a/dev-libs/sdformat/sdformat-9.8.0.ebuild
+++ b/dev-libs/sdformat/sdformat-9.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,7 @@ BDEPEND="
dev-lang/ruby:*
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/ruby.patch" )
src_prepare() {
cmake_src_prepare