summaryrefslogtreecommitdiff
path: root/dev-libs/uthash/uthash-1.9.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/uthash/uthash-1.9.7.ebuild')
-rw-r--r--dev-libs/uthash/uthash-1.9.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/uthash/uthash-1.9.7.ebuild b/dev-libs/uthash/uthash-1.9.7.ebuild
new file mode 100644
index 000000000000..84b1558ab1c8
--- /dev/null
+++ b/dev-libs/uthash/uthash-1.9.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="http://uthash.sourceforge.net"
+SRC_URI="mirror://sourceforge/uthash/${P}.tar.bz2"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 sparc x86"
+IUSE="test"
+
+DEPEND="test? ( dev-lang/perl )"
+RDEPEND=""
+
+src_test() {
+ cd tests
+ sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die "sed cflags failed"
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/*.h || die "doins failed"
+
+ dodoc doc/txt/{ChangeLog,userguide,ut*}.txt
+}