summaryrefslogtreecommitdiff
path: root/dev-ml/cppo/cppo-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/cppo/cppo-1.5.0.ebuild')
-rw-r--r--dev-ml/cppo/cppo-1.5.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ml/cppo/cppo-1.5.0.ebuild b/dev-ml/cppo/cppo-1.5.0.ebuild
index edc62efc16d9..f6525a761bd7 100644
--- a/dev-ml/cppo/cppo-1.5.0.ebuild
+++ b/dev-ml/cppo/cppo-1.5.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit findlib
@@ -27,9 +27,11 @@ src_compile() {
src_install() {
findlib_src_preinst
+
mkdir -p "${ED}"/usr/bin
emake PREFIX="${ED}"/usr BEST="$(usex ocamlopt '.native' '.byte')" install
dodoc README.md Changes
+
if use examples ; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples